Bug 168823 - File conflicts between 32bit and 64bit packages
File conflicts between 32bit and 64bit packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 11:06 EDT by Phil Knirsch
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version: pam-0.80-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 12:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2005-09-20 11:06:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
File conflicts exists between the installed 32bit and 64bit packages:

Error: pam-0.80-7.i386 file conflicts with:
Error:  '/usr/share/doc/pam-0.80/pdf/pam.pdf' <=> pam-0.80-7.x86_64
Error:  '/usr/share/doc/pam-0.80/pdf/pam_appl.pdf' <=> pam-0.80-7.x86_64
Error:  '/usr/share/doc/pam-0.80/pdf/pam_modules.pdf' <=> pam-0.80-7.x86_64
Error:  '/usr/share/doc/pam-0.80/ps/pam.ps' <=> pam-0.80-7.x86_64
Error:  '/usr/share/doc/pam-0.80/ps/pam_modules.ps' <=> pam-0.80-7.x86_64
Error:  '/usr/share/doc/pam-0.80/ps/pam_appl.ps' <=> pam-0.80-7.x86_64


Version-Release number of selected component (if applicable):
pam-0.80-7

How reproducible:
Always

Steps to Reproduce:
1. Use a file conflict enabled rpm to install both 32bit and 64bit versions of this package
2.
3.
  

Actual Results:  See listed file conflicts in description


Expected Results:  No file conflicts


Additional info:
Comment 1 Tomas Mraz 2005-09-20 11:15:58 EDT
I'm not sure how to fix this. Either we can move the docs to -devel subpackage,
create a new -doc subpackage or remove the pdf and ps versions completely.
Comment 2 Phil Knirsch 2005-09-21 04:16:57 EDT
The problem is that moving the ps and pdf files to different packages won't
change the fact that if you then try to install those packages for 32bit and
64bit at the same time you'd end up having file conflicts again.

The only 3 possible solutions i know of are these:

1) Easy mode: drop the ps and pdf files
2) Harder mode: Change the filespec so that for the doc files no fileconflict
checks are done (disable the checks basically)
3) Hardest mode: Make sure the files are identical for 32bit and 64bit, which i
belive is nearly impossible for autogenerated ps and pdf files as the contain a
timestamp.

So i belive either 1 or 2 should be done, depending on wether the ps and pdf
files are really needed or not.

Read ya, Phil
Comment 3 Tomas Mraz 2005-09-29 08:01:30 EDT
Hmm I see that -devel subpackage is actually installed multilib on all arches
except ia64. So a new subpackage -doc would have to be created or drop the ps
and pdf files completely. The -doc subpackage wouldn't be installed multilib so
the problem of conflicting files would be moot.
Comment 4 Tomas Mraz 2005-09-30 12:38:15 EDT
Fixed by removing the ps and pdf docs.

Note You need to log in before you can comment on or make changes to this bug.