Bug 1688311 - [upgrades] logs usability on undercloud upgrade to osp15
Summary: [upgrades] logs usability on undercloud upgrade to osp15
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Alex Schultz
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 14:16 UTC by Ronnie Rasouli
Modified: 2019-09-26 10:48 UTC (History)
2 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.4.1-0.20190329120340.748499d.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:20:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
install log upgrade failure (509.24 KB, text/plain)
2019-03-13 14:16 UTC, Ronnie Rasouli
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1819931 0 None None None 2019-03-13 15:14:24 UTC
OpenStack gerrit 643071 0 None None None 2019-03-13 15:14:24 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:47 UTC

Description Ronnie Rasouli 2019-03-13 14:16:22 UTC
Created attachment 1543681 [details]
install log upgrade failure

Description of problem:

Searching for the root cause error of upgrade failure does not tell what is error for upgrade failure:

on install-undercloud there is only 1 entry for the failure

2019-03-13 13:07:08.697 79966 WARNING tripleoclient.v1.tripleo_deploy.Deploy [  admin]         "2019-03-13 13:05:47,450 ERROR: 84000 -- Failed running container for neutron",

Then many error entries on log:


2019-03-13 13:07:09.684 79966 ERROR openstack [  admin] Deployment failed.
2019-03-13 13:07:09.878 79957 ERROR tripleoclient.v1.undercloud.InstallUndercloud [  ]

There is no root cause error for the failure. 

Version-Release number of selected component (if applicable):
osp15 REHL8.0 Beta

2019-03-06.1
How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

The root cause was hidden for openvswitch hasn't been started

Container-puppet for Neutron: run failed after error checking path \"/run/openvswitch\": stat /run/openvswitch: no such file or directory",

Comment 1 Alex Schultz 2019-03-13 14:52:17 UTC
It's in the log,

2019-03-13 13:07:08.697 79966 WARNING tripleoclient.v1.tripleo_deploy.Deploy [  admin]         "2019-03-13 13:05:40,894 WARNING: 84000 -- ['/usr/bin/podman', 'run', '--user', 'root', '--name', 'container-puppet-neutron', '--env', 'PUPPET_TAGS=file,file_line,concat,augeas,cron,neutron_config,ironic_neutron_agent_config,neutron_config,neutron_api_config,neutron_plugin_ml2,neutron_config,neutron_dhcp_agent_config,neutron_config,neutron_l3_agent_config,neutron_config,neutron_agent_ovs,neutron_plugin_ml2', '--env', 'NAME=neutron', '--env', 'HOSTNAME=undercloud-0', '--env', 'NO_ARCHIVE=', '--env', 'STEP=6', '--env', 'NET_HOST=true', '--log-driver', 'json-file', '--volume', '/etc/localtime:/etc/localtime:ro', '--volume', '/tmp/tmpcwn5_jsm:/etc/config.pp:ro', '--volume', '/etc/puppet/:/tmp/puppet-etc/:ro', '--volume', '/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.trust.crt:ro', '--volume', '/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro', '--volume', '/var/lib/config-data:/var/lib/config-data/:rw', '--volume', '/dev/log:/dev/log:rw', '--log-opt', 'path=/var/log/containers/stdouts/container-puppet-neutron.log', '--security-opt', 'label=disable', '--volume', '/usr/share/openstack-puppet/modules/:/usr/share/openstack-puppet/modules/:ro', '--volume', '/lib/modules:/lib/modules:ro', '--volume', '/run/openvswitch:/run/openvswitch:shared,z', '--entrypoint', '/var/lib/container-puppet/container-puppet.sh', '--net', 'host', '--volume', '/etc/hosts:/etc/hosts:ro', '--volume', '/var/lib/container-puppet/container-puppet.sh:/var/lib/container-puppet/container-puppet.sh:ro', '192.168.24.1:8787/rhosp15/openstack-neutron-server:latest'] run failed after error checking path \"/run/openvswitch\": stat /run/openvswitch: no such file or directory",

This probably should be an ERROR and not a warning though

Comment 6 errata-xmlrpc 2019-09-21 11:20:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.