Bug 1688318 - PVC resize fails from webconsole if limits are set
Summary: PVC resize fails from webconsole if limits are set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.11.z
Assignee: Ankush Behl
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1700182 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 14:30 UTC by Matthew Robson
Modified: 2019-06-26 09:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-26 09:07:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:08:04 UTC

Description Matthew Robson 2019-03-13 14:30:03 UTC
Description of problem:

Trying to resize a PVC from the console always fails if the project has a limitrange set.

Error: "Can't be greater than ."

If you delete the limitrange, the resize works without issue.

Reported here: https://github.com/openshift/origin-web-console/issues/3096

Version-Release number of selected component (if applicable):

3.11.59

How reproducible:

Always

Steps to Reproduce:
1. Create PVC
2. Resize from oc edit pvc works
3. Create new PVC
4. Resize from PVC -> Actions -> Expand PVC
5. Error: "Can't be greater than ."
6. oc delete resourcequota --all
7. refresh console, still fails
8. oc delete LimitRange --all
9. Refresh and resize works

Actual results:

Resize fails with Error: "Can't be greater than ."


Expected results:

Successful resize

Additional info:

Comment 1 Samuel Padgett 2019-03-13 16:33:58 UTC
Ankush, are you able to look at this?

Comment 2 Ankush Behl 2019-03-15 18:44:45 UTC
Sam, Looking into this will update once the fix is available.

Comment 4 Yadan Pei 2019-03-26 08:34:05 UTC
QE tried to reproduce the issue with steps

1. Create StorageClass with allowVolumeExpansion: true
oc get sc standard-testing -o yaml
allowVolumeExpansion: true
apiVersion: storage.k8s.io/v1
kind: StorageClass
metadata:
  annotations:
    storageclass.beta.kubernetes.io/is-default-class: "false"
  creationTimestamp: 2019-03-26T03:20:11Z
  name: standard-testing
  resourceVersion: "39761"
  selfLink: /apis/storage.k8s.io/v1/storageclasses/standard-testing
  uid: 107d14f9-4f76-11e9-8b5a-fa163ede2042
parameters:
  fstype: xfs
provisioner: kubernetes.io/cinder
reclaimPolicy: Delete
volumeBindingMode: Immediate
2. Create Resource Quota 
apiVersion: v1
kind: ResourceQuota
metadata:
  name: quota-pvc-storage
spec:
  hard:
    persistentvolumeclaims: "1"
    requests.storage: "1Gi"
3. Create PVC using sc/standard-testing and set size to 500MiB, PVC will be bound
4. Goes to Storage -> mypvc -> Actions -> Expand PVC
5. Try to set Capacity to 500GiB, it will show error message " Storage quota will be exceeded. View Quota " and Expand button will be disabled, user can't expand to larger value
6. Try to set Capacity to 1GiB(quota limit), it can be expanded to 1GiB

this is checked on openshift v3.11.100

Comment 5 Yadan Pei 2019-03-26 08:35:21 UTC
Didn't see error 'Can't be greater than .', will give another try on 3.11.59 tomorrow

Comment 6 Samuel Padgett 2019-04-18 13:18:43 UTC
*** Bug 1700182 has been marked as a duplicate of this bug. ***

Comment 8 Yadan Pei 2019-04-22 08:00:18 UTC
1. Create LimitRange 
# oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/limits/limits.yaml -n testproject
2. Create StorageClass with allowVolumeExpansion set to true
3. Create PVC using this storageclass
4. Goes to Storage -> mypvc -> Actions -> Expand PVC, there is error " Can't be greater than . " and not be able to expand PVC

This is reproduced on v3.11.59

Having LimitRange in project prevents user from expanding PVC. Having ResourceQuota doesn't affect the function

Comment 16 Yadan Pei 2019-06-14 09:07:13 UTC
1. Create StorageClass
allowVolumeExpansion: true
apiVersion: storage.k8s.io/v1
kind: StorageClass
metadata:
  name: standard-testing
parameters:
  fstype: xfs
provisioner: kubernetes.io/aws-ebs
reclaimPolicy: Delete
volumeBindingMode: Immediate
2. Create LimitRange in project
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/limits/limits.yaml -n testproject
3. Create PVC with capacity set as 500MiB
4. Expand PVC to 510MiB via Actions -> Expand PVC 

PVC can be successfully extended.

Verified on OpenShift Web Console:v3.11.117

Comment 18 errata-xmlrpc 2019-06-26 09:07:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605


Note You need to log in before you can comment on or make changes to this bug.