Bug 1688371 - Program tuned tried to access /dev/mem between f0000->100000.
Summary: Program tuned tried to access /dev/mem between f0000->100000.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.7
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 15:59 UTC by Steve Best
Modified: 2019-08-06 13:05 UTC (History)
5 users (show)

Fixed In Version: tuned-2.11.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:04:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
console log (85.76 KB, text/plain)
2019-03-13 15:59 UTC, Steve Best
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2201 None None None 2019-08-06 13:05:18 UTC

Description Steve Best 2019-03-13 15:59:29 UTC
Created attachment 1543696 [details]
console log

Description of problem:
during boot the following msg is displayed
Program tuned tried to access /dev/mem between f0000->100000.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Install RHEL 7,7 ( was using 	RHEL-7.7-20190312.n.0 Server ppc64le)
2.view console
3.

Actual results:
Program tuned tried to access /dev/mem between f0000->100000.

Expected results:
no msg from tuned

Additional info:
[root@ibm-p8-rhevm-18 /]# rpm -qa tuned
tuned-2.11.0-0.1.rc1.el7.noarch
[root@ibm-p8-rhevm-18 /]#

Comment 2 Jaroslav Škarvada 2019-03-14 09:31:03 UTC
I guess it could be related to the dmidecode python library - I am going to check.

Comment 3 Jaroslav Škarvada 2019-03-14 10:03:20 UTC
(In reply to Jaroslav Škarvada from comment #2)
> I guess it could be related to the dmidecode python library - I am going to
> check.

Yes, it's caused by the python-dmidecode package, I will open bug against it:

bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com tuned[5459]: ** COLLECTED WARNINGS **
bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com tuned[5459]: /dev/mem (mmap): Operation not permitted
bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com tuned[5459]: No SMBIOS nor DMI entry point found, sorry.
bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com tuned[5459]: ** END OF WARNINGS **
bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com systemd[1]: Stopped Dynamic System Tuning Daemon.
bře 14 05:49:31 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com polkitd[5060]: Unregistered Authentication Agent for unix-process:13490:17123 (system bus name :1.21, object path /org
bře 14 05:49:33 ibm-p8-kvm-09-guest-14.virt.pnr.lab.eng.rdu2.redhat.com kernel: Program tuned tried to access /dev/mem between f0000->100000.

We will probably workaround it in the Tuned.

Simple workaround:
# rpm -e --nodeps python-dmidecode

and the error should gone.

Comment 5 Jaroslav Škarvada 2019-03-14 10:27:04 UTC
Filled python-dmidecode bug 1688725

Comment 6 Jaroslav Škarvada 2019-03-14 14:49:19 UTC
Fixed by following upstream commit:
https://github.com/redhat-performance/tuned/commit/9d83b77572a34c9822c626d0f48eac4a547c5a8f

Comment 16 errata-xmlrpc 2019-08-06 13:04:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2201


Note You need to log in before you can comment on or make changes to this bug.