Bug 168839 - Keeps requesting WEP key when DHCP fails
Keeps requesting WEP key when DHCP fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 11:45 EDT by Neil Weisenfeld
Modified: 2008-02-28 20:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 20:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Weisenfeld 2005-09-20 11:45:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
I'm supplying a valid WEP key and, according to iwconfig, are associating with an access point correctly.  This connection has worked fine in the past.  Today our DHCP server was down and the response of NetworkManager was to keep asking over and over again for the WEP key.  Clearly the WEP key was not the issue here and the program should respond with a message that the DHCP connection failed.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set up a network which requires WEP and has a stand-alone DHCP server
2.connect with a proper WEP key
3.verify that things worked correctly and shut down connection
4.disable the DHCP server on the network
5.attempt to enable the connection
  

Actual Results:  asked for WEP key over and over

Expected Results:  Since the WEP key was accepted and we properly associated with the access point, but DHCP negotiation failed, an error message should be generated that DHCP negotiation failed.

Additional info:
Comment 1 Dan Williams 2005-09-20 13:00:08 EDT
Unfortunately it's not quite that easy, as there is no way to really know if the
WEP key is right or wrong.  The only way to know if the WEP key is really wrong
is if you can't get a DHCP address from the access point.

However, that case obviously overlaps with the case where the DHCP server also
doesn't respond.  I'm not quite sure how to proceed with this, but I'll try to
think of something.  Perhaps just a count of wrong WEP keys entered, after 4 or
something it just says "sorry, can't connect".
Comment 3 Christian Iseli 2007-01-19 19:55:33 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 4 Neil Weisenfeld 2007-01-22 11:42:08 EST
(In reply to comment #3)

Hi Christian, I would probably EOL the bug report since it's from stale versions
of Fedora.  I don't have any Fedora systems around and can't install one on a
laptop just for testing this.  The assertion in the first comment was that the
problem was unfixable and while I don't understand that, I'm sure that my the
commenter knows far more than I do about these things.


Best regards.

Note You need to log in before you can comment on or make changes to this bug.