Bug 1688517 - UPGRADE openshift-authentication operator not reporting operator version
Summary: UPGRADE openshift-authentication operator not reporting operator version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Standa Laznicka
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 21:52 UTC by Derek Carr
Modified: 2019-06-04 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:54 UTC

Description Derek Carr 2019-03-13 21:52:53 UTC
Description of problem:
openshift-authentication operator not reporting clusteroperator version

Version-Release number of selected component (if applicable):
4.0.0-0.alpha-2019-03-13-010143

How reproducible:
Always

Actual results:
oc get clusteroperators openshift-authentication
NAME                       VERSION   AVAILABLE   PROGRESSING   FAILING   SINCE
openshift-authentication             False       False         True      14h


Expected results:
Version reports the payload version when it achieves level.


Additional info:

Comment 1 Standa Laznicka 2019-03-15 08:02:22 UTC
The basic implementation solving operator version got merged: https://github.com/openshift/cluster-authentication-operator/pull/94

Comment 4 errata-xmlrpc 2019-06-04 10:45:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.