Bug 1688519 - UPGRADE service-ca operator not reporting payload version
Summary: UPGRADE service-ca operator not reporting payload version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Sally
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-13 21:54 UTC by Derek Carr
Modified: 2019-06-04 10:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:54 UTC

Description Derek Carr 2019-03-13 21:54:46 UTC
Description of problem:
service-ca operator not reporting clusteroperator version

Version-Release number of selected component (if applicable):
4.0.0-0.alpha-2019-03-13-010143

How reproducible:
Always

Actual results:
oc get clusteroperators service-ca
NAME                       VERSION   AVAILABLE   PROGRESSING   FAILING   SINCE
service-ca             False       False         True      14h


Expected results:
Version reports the payload version when it achieves level.

Comment 3 Chuan Yu 2019-03-22 06:06:23 UTC
Verified.

$ oc get clusteroperator service-ca
NAME         VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
service-ca   4.0.0-0.nightly-2019-03-22-032251   True        False         False     14m

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-22-032251   True        False         23s     Cluster version is 4.0.0-0.nightly-2019-03-22-032251

Comment 5 errata-xmlrpc 2019-06-04 10:45:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.