Bug 1688643 - "error: ../../grub-core/commands/test.c:436:false." during boot
Summary: "error: ../../grub-core/commands/test.c:436:false." during boot
Keywords:
Status: CLOSED DUPLICATE of bug 1699761
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 07:14 UTC by Phil Wyett
Modified: 2019-07-28 07:22 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-15 09:56:49 UTC


Attachments (Terms of Use)
Screenshot of error. (33.91 KB, image/png)
2019-03-14 07:14 UTC, Phil Wyett
no flags Details

Description Phil Wyett 2019-03-14 07:14:06 UTC
Created attachment 1543914 [details]
Screenshot of error.

Description of problem:

Error on boot - not fatal.

Message:

error: ../../grub-core/commands/test.c:436:false

Install is 30 branched 2019-03-12 workstation VM (QEMU/KVM) on RHEL 7.x.

Version-Release number of selected component (if applicable):

2.02-72

How reproducible:

Always.

Steps to Reproduce:
1. Install fedora 30 branched 2019-02-12 workstation.
2. Boot.

Actual results:

Error.

Message:

error: ../../grub-core/commands/test.c:436:false

Expected results:

No errors.

Additional info:

Comment 1 Phil Wyett 2019-03-18 15:12:08 UTC
Installed f30 drop 20190316 and error no longer occurs.

Closing bug.

Comment 2 Phil Wyett 2019-03-21 17:36:17 UTC
Error was gone in drop 2019-03-16, but is back in pre beta drop 1.4 2019-03-20.

Comment 3 Phil Wyett 2019-03-24 10:37:26 UTC
Issue does not appear when running f30 pre beta 1.7 compose.

Closing for hopefully the last time. :-D

Comment 4 dirk 2019-05-01 15:17:34 UTC
I still have this message.

A few days ago I installed from Live F30 beta 1.8 (March 26, 2019). Since then I updated every day. 

I also reinstalled (today, May 1) grub2*, executed grub2-install, also 
grub2-mkconfig -o /boot/grub2/grub.cfg

So in principal I should now on the same level of an updated F30 release, right? What can I do else?

Comment 5 joshas 2019-05-02 18:39:41 UTC
I get the same error message on boot.
Installed from Fedora-Workstation-Live-x86_64-30-1.2.iso to virtual machine using VirtualBox 6.0.6. Used automatic disk partitioning.
Is there any more information I could provide to help fix this issue?

Comment 6 Richard Fearn 2019-05-04 13:58:02 UTC
Reopening because this is still happening with a fresh install of F30

Comment 7 MicMor 2019-05-08 03:48:52 UTC
Same mistake for me, with a fresh install of F30

Comment 8 Paul Lazaga 2019-05-08 03:54:45 UTC
I'm receiving the same error on a fresh install of F30 on x64 hardware, not a VM. No automatic partitioning, as it is previous install /home directory after F29 >> F30 upgrade resulted in damaged grub leaving me at the GRUB> prompt. No selection of kernel/boot is possible, it boots directly to most recent.

Comment 9 Douglas Márquez 2019-05-10 19:42:18 UTC
Made 5 installation on actual hardware from Fedora-Silverblue-ostree-x86_64-30-1.2.iso following this steps in no particular order:

- Selected Spanish (Venezuela)
- Changed keyboard distribution from Español(Latinoamerica) to Español(Español)
- Picked Caracas, Venezuela (-4) AM/PM
- Used full disk automatic partitioning (640GB), then the installer asked for space (reclaim space -> delete all). Then selected full disk encryption.
- Selected WiFi connection.
- Go to install.
- Configured root password.
- Added a normal user.

On first installation, instead of grub menu, I got the message: error: ../../grub-core/commands/test.c:436:false.

On second installation, after reboot, it didn't show error message but grub menu as expected. After first login, updated system with "rpm-ostree upgrade", then reboot with "systemctl reboot" and got "error: ../../grub-core/commands/test.c:436:false" again instead of grub menu.

On every installation after that, got the same error message since first reboot.

Comment 10 Nikato Muirhead 2019-05-14 17:33:00 UTC
I can confirm that this issue is happening with my install of F30 as well. Fresh install using automatic partitioning. This impacts what would have been an otherwise silent and neat boot-up

Comment 11 andor.ugalde 2019-05-14 23:04:54 UTC
Did a fresh install of Fedora 30 today and ran into this issue as well. Anybody know where the path it makes reference to is located?  Has anyone figured out were the request for file test.c is comming from?

Comment 12 Javier Martinez Canillas 2019-05-15 09:56:49 UTC

*** This bug has been marked as a duplicate of bug 1699761 ***

Comment 13 Richard Fearn 2019-05-15 10:24:24 UTC
(In reply to andor.ugalde from comment #11)

> Anybody know where the path it makes reference to is located?  Has anyone
> figured out were the request for file test.c is comming from?

http://git.savannah.gnu.org/cgit/grub.git/tree/grub-core/commands/test.c#n436

Comment 14 Javier Martinez Canillas 2019-05-15 10:31:48 UTC
I've pushed an update that should fix this bug: https://bodhi.fedoraproject.org/updates/grub2-2.02-80.fc30

Comment 15 Sean Rhone 2019-05-23 19:16:47 UTC
Still happening; just installed F30 clean (BIOS/Legacy boot), distro-sync'd it (have grub2-common 2.02-81-fc30) and I get the same error on start-up.

I installed F30 with a custom partitioning set-up to a blank drive (only /, /boot/ and swap; both /boot and / as XFS). The computer I installed to is running Coreboot with SeaBIOS.

Comment 16 Javier Martinez Canillas 2019-05-23 20:31:46 UTC
(In reply to Sean Rhone from comment #15)
> Still happening; just installed F30 clean (BIOS/Legacy boot), distro-sync'd
> it (have grub2-common 2.02-81-fc30) and I get the same error on start-up.
> 
> I installed F30 with a custom partitioning set-up to a blank drive (only /,
> /boot/ and swap; both /boot and / as XFS). The computer I installed to is
> running Coreboot with SeaBIOS.

GRUB core.img isn't updated on package upgrade for legacy BIOS installs, you need to execute grub2-install /dev/sda (replace sda for your actual block device).

Comment 17 Federico Bruni 2019-07-28 07:22:33 UTC
Can you explain how to make the error go away?

I have this error since I installed Fedora 30 (from scratch, not an update).
The system is up to date, but the error still appears.

Today I've tried the following:

    sudo dnf reinstall grub2*
    sudo cp /boot/grub2/grub.cfg /boot/grub2/grub.cfg.backup
    sudo grub2-mkconfig -o /boot/grub2/grub.cfg

I've restarted the system but the error is still printed.


Note You need to log in before you can comment on or make changes to this bug.