Bug 1688686 - Old CRD 'networkconfigs.networkoperator.openshift.io' should be deleted
Summary: Old CRD 'networkconfigs.networkoperator.openshift.io' should be deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.1.0
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Ricardo Carrillo Cruz
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 08:45 UTC by zhaozhanqi
Modified: 2019-06-04 10:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:56 UTC

Description zhaozhanqi 2019-03-14 08:45:26 UTC
Description of problem:
From this PR https://github.com/openshift/cluster-network-operator/pull/120

The crd networkconfigs.networkoperator.openshift.io has been changed to 'networks.operator.openshift.io', but found the old CRD networkconfigs.networkoperator.openshift.io still exist in the cluster

# oc get crd | grep network
clusternetworks.network.openshift.io                        2019-03-14T07:06:06Z
egressnetworkpolicies.network.openshift.io                  2019-03-14T07:06:07Z
hostsubnets.network.openshift.io                            2019-03-14T07:06:06Z
netnamespaces.network.openshift.io                          2019-03-14T07:06:07Z
network-attachment-definitions.k8s.cni.cncf.io              2019-03-14T07:06:03Z
networkconfigs.networkoperator.openshift.io                 2019-03-14T07:05:20Z
networks.config.openshift.io                                2019-03-14T07:05:19Z
networks.operator.openshift.io                              2019-03-14T07:05:34Z

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-13-233958

How reproducible:
always

Steps to Reproduce:
1. setup env using payload version 4.0.0-0.nightly-2019-03-13-233958
  
2. oc get crd | grep network
3.

Actual results:

networkconfigs.networkoperator.openshift.io still exist

Expected results:

'networkconfigs.networkoperator.openshift.io' should be deleted since it has changed to 'networks.operator.openshift.io'

Additional info:

Comment 1 Casey Callendrello 2019-03-14 09:53:51 UTC
PR https://github.com/openshift/installer/pull/1410 filed.

Comment 2 Ben Bennett 2019-03-27 14:48:35 UTC
Ricardo: Can you keep an eye on that PR and make sure it gets in please?

Comment 3 Ricardo Carrillo Cruz 2019-03-28 09:33:02 UTC
https://github.com/openshift/installer/pull/1410 was merged, closing the bug.

Comment 4 Ricardo Carrillo Cruz 2019-03-28 10:21:41 UTC
Per conversation with Bo Meng about bug workflow, bugs on POST are picked up by ART team, verified once the PR is put in a build then it moves to ON_QA.
Thus reopening.

Comment 6 zhaozhanqi 2019-03-29 03:18:28 UTC
Verified this bug on 4.0.0-0.nightly-2019-03-28-030453

networkconfigs.networkoperator.openshift.io had been removed.

Comment 8 errata-xmlrpc 2019-06-04 10:45:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.