Bug 168870 - Whenever there is a crash, documents that were open are not recovered
Whenever there is a crash, documents that were open are not recovered
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 15:24 EDT by David
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 15:30:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2005-09-20 15:24:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Recently I lost some important data due to a crash.

I decided to file this bug because whenever there is a crash (I have been having some not deterministic ones), documents that were open are not recovered.

I googled and found that supposedly OO.org 2 beta has this facility as 1.3 had that worked very fine. See:

http://www.oooforum.org/forum/viewtopic.phtml?t=20840

Was this purposedly left out FC4? If so why?



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Wait for a crash
2. Re-open OO.org
  

Actual Results:  Only a blank document is opened

Expected Results:  Document recovery wizzard should appear with a list of open documents before the crash to be recovered

Additional info:
Comment 1 Caolan McNamara 2005-09-20 15:30:54 EDT
Red Hat reviews and scrubs its code for intellectual property issues. Our
approach has always been conservative, i.e., if there is any question, resolve
the issue or remove the code.  Red Hat recently implemented a number of changes
in its distribution of OpenOffice to address such issues.  These changes should
not be construed as implying any immediate intellectual property problem;
rather, they have been implemented to assure that no such immeidate problems
arise. While implementing these changes in our own distribution of OpenOffice,
we have also made them available upstream to the OpenOffice project.
Comment 2 David 2005-09-20 15:37:02 EDT
I'm sorry, I didn't understand your answer... do you mean the recovery wizzard
has intellectual property issues? If it does, why OO.org in FC3 did have that
wizzard? And if it has IP issues why don't you implement an alternative recovery
process. Because it's still a beta version, it is very prone to crashes and
severe data loss can occur...

Note You need to log in before you can comment on or make changes to this bug.