Bug 1688713 - The olm operators version inappropriate in ClusterOperator
Summary: The olm operators version inappropriate in ClusterOperator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 10:04 UTC by Jian Zhang
Modified: 2019-06-04 10:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:56 UTC

Description Jian Zhang 2019-03-14 10:04:13 UTC
Description of problem:
The OLM operator version info is inappropriate in ClusterOperator.

Version-Release number of selected component (if applicable):
OLM image info:
               io.openshift.build.commit.id=840d806a3b20e5ebb7229631d0168864b1cfed12
               io.openshift.build.commit.url=https://github.com/operator-framework/operator-lifecycle-manager/commit/840d806a3b20e5ebb7229631d0168864b1cfed12
               io.openshift.build.source-location=https://github.com/operator-framework/operator-lifecycle-manager

CLuster version:
4.0.0-0.nightly-2019-03-13-233958

How reproducible:
always


Steps to Reproduce:
1. Install the OCP 4.0.
2. Check the clusteroperator resource.


Actual results:
[jzhang@dhcp-140-18 ocp14]$ oc get clusteroperator
NAME                                  VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
cluster-autoscaler                    4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h13m
console                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     114m
dns                                   4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h12m
image-registry                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h7m
ingress                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h7m
kube-apiserver                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h11m
kube-controller-manager               4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h12m
kube-scheduler                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h12m
machine-api                           4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h13m
machine-config                        4.0.0-0.nightly-2019-03-13-233958   True        False         False     148m
marketplace-operator                  4.0.0-0.nightly-2019-03-13-233958   True        False         False     154m
monitoring                            4.0.0-0.nightly-2019-03-13-233958   True        False         False     112m
network                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h7m
node-tuning                           4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h8m
openshift-apiserver                   4.0.0-0.nightly-2019-03-13-233958   True        False         False     12m
openshift-authentication                                                  True        False         False     114m
openshift-cloud-credential-operator                                       True        False         False     6h13m
openshift-controller-manager          4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h8m
openshift-samples                     4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h6m
operator-lifecycle-manager            0.8.1-31e16a9                       True        False         False     6h13m
service-ca                                                                True        False         False     6h13m
service-catalog-apiserver             4.0.0-0.nightly-2019-03-13-233958   True        False         False     11m
service-catalog-controller-manager    4.0.0-0.nightly-2019-03-13-233958   True        False         False     93m
storage                               4.0.0-0.nightly-2019-03-13-233958   True        False         False     6h8m

Expected results:
The operator-lifecycle-manager  should display the cluster version.

Additional info:

Comment 1 Evan Cordell 2019-03-17 15:23:55 UTC
This is fixed in: https://github.com/operator-framework/operator-lifecycle-manager/pull/748

Comment 3 Jian Zhang 2019-03-19 08:10:15 UTC
OLM version commit: io.openshift.build.commit.id=69457423c2da01da0110b17fac1ac48b994b99e8
Cluster version is 4.0.0-0.nightly-2019-03-18-200009

[jzhang@dhcp-140-18 ocp119]$ oc get clusteroperator
NAME                                  VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
authentication                        4.0.0-0.nightly-2019-03-18-200009   True        False         False     37m
cluster-autoscaler                    4.0.0-0.nightly-2019-03-18-200009   True        False         False     42m
console                               4.0.0-0.nightly-2019-03-18-200009   True        False         False     33m
dns                                   4.0.0-0.nightly-2019-03-18-200009   True        False         False     44m
image-registry                        4.0.0-0.nightly-2019-03-18-200009   True        False         False     36m
ingress                               4.0.0-0.nightly-2019-03-18-200009   True        False         False     37m
kube-apiserver                        4.0.0-0.nightly-2019-03-18-200009   True        False         False     40m
kube-controller-manager               4.0.0-0.nightly-2019-03-18-200009   True        False         False     40m
kube-scheduler                        4.0.0-0.nightly-2019-03-18-200009   True        False         False     41m
machine-api                           4.0.0-0.nightly-2019-03-18-200009   True        False         False     45m
machine-config                        4.0.0-0.nightly-2019-03-18-200009   True        False         False     43m
marketplace-operator                  4.0.0-0.nightly-2019-03-18-200009   True        False         False     37m
monitoring                            4.0.0-0.nightly-2019-03-18-200009   True        False         False     34m
network                               4.0.0-0.nightly-2019-03-18-200009   True        False         False     45m
node-tuning                           4.0.0-0.nightly-2019-03-18-200009   True        False         False     37m
openshift-apiserver                   4.0.0-0.nightly-2019-03-18-200009   True        False         False     34m
openshift-cloud-credential-operator   4.0.0-0.nightly-2019-03-18-200009   True        False         False     45m
openshift-controller-manager          4.0.0-0.nightly-2019-03-18-200009   True        False         False     39m
openshift-samples                     4.0.0-0.nightly-2019-03-18-200009   True        False         False     36m
operator-lifecycle-manager            4.0.0-0.nightly-2019-03-18-200009   True        False         False     44m
service-ca                                                                True        False         False     42m
service-catalog-apiserver             4.0.0-0.nightly-2019-03-18-200009   True        False         False     38m
service-catalog-controller-manager    4.0.0-0.nightly-2019-03-18-200009   True        False         False     38m
storage                               4.0.0-0.nightly-2019-03-18-200009   True        False         False     38m

[jzhang@dhcp-140-18 ocp119]$ oc get clusteroperator operator-lifecycle-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: 2019-03-19T07:21:00Z
  generation: 1
  name: operator-lifecycle-manager
  resourceVersion: "1977"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/operator-lifecycle-manager
  uid: 8c2d2ee8-4a17-11e9-b038-02e816726d9a
spec: {}
status:
  conditions:
  - lastTransitionTime: 2019-03-19T07:21:00Z
    status: "False"
    type: Failing
  - lastTransitionTime: 2019-03-19T07:21:00Z
    message: Deployed 0.8.1
    status: "False"
    type: Progressing
  - lastTransitionTime: 2019-03-19T07:21:00Z
    status: "True"
    type: Available
  extension: null
  relatedObjects: null
  versions:
  - name: operator
    version: 4.0.0-0.nightly-2019-03-18-200009
  - name: operator-lifecycle-manager
    version: 0.8.1

LGTM, verify it.

Comment 5 errata-xmlrpc 2019-06-04 10:45:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.