Bug 1688779 - First build of an s2i incremental build fails with "Error reading manifest latest"
Summary: First build of an s2i incremental build fails with "Error reading manifest la...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 12:28 UTC by Marek Schmidt
Modified: 2019-06-04 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:56 UTC

Description Marek Schmidt 2019-03-14 12:28:28 UTC
Description of problem:

Running an incremental s2i build for a first time fails attempting to read the previous image (which doesn't yet exist):

Caching blobs under "/var/cache/blobs".
Pulling docker://image-registry.openshift-image-registry.svc:5000/openshift/jboss-eap72-openshift@sha256:f9b04617b0c44f856fd85283d5f9c94d4453eb30772380950fc4fca675019e2e
Getting image source signatures
Copying blob sha256:2cb1196a3b2716c68f8ba88205548a9f659e98edc30898ca3a7c762b4d5e0190
Copying blob sha256:c9c433594a59dca1d747e916d5403e64705d217dac148804bcbcd712392141a8
Copying blob sha256:6be769b53a94f4e8b380d4a57ad520214905ecc5cae9f752ab2e80dd94b6f7b3
Copying config sha256:97a4bb1b64dd930e8095c97abdbcc5bad0905fc1ba98aaa2d3317a797301bde5
Writing manifest to image destination
Storing signatures
97a4bb1b64dd930e8095c97abdbcc5bad0905fc1ba98aaa2d3317a797301bde5
Generating dockerfile with builder image image-registry.openshift-image-registry.svc:5000/openshift/jboss-eap72-openshift@sha256:f9b04617b0c44f856fd85283d5f9c94d4453eb30772380950fc4fca675019e2e
STEP 1: FROM image-registry.openshift-image-registry.svc:5000/maschmid/eap-app:latest AS cached
error: build error: error creating build container: Error determining manifest MIME type for docker://image-registry.openshift-image-registry.svc:5000/maschmid/eap-app:latest: Error reading manifest latest in image-registry.openshift-image-registry.svc:5000/maschmid/eap-app: manifest unknown: manifest unknown


Version-Release number of selected component (if applicable):
oc v4.0.0-0.139.0
kubernetes v1.12.4+0f8e04e
Cluster version is 4.0.0-0.7

How reproducible:
always

Steps to Reproduce:
1. oc new-app eap72-basic-s2i

Actual results:
Build fails with the error described above

Expected results:
Build should complete

Additional info:
This is a regression compared to OCP 3.11 behavior, the same template works fine there.

Comment 1 Adam Kaplan 2019-03-14 19:45:22 UTC
PR: https://github.com/openshift/builder/pull/52

Comment 3 wewang 2019-03-20 03:21:52 UTC
Verified in version:
         registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-03-18-200009
payload: registry.svc.ci.openshift.org/ocp/release@sha256:e1d7ed4379ed7507e6a74cdc121c0deb9fe093cde2eb2285058ddd5a847a724d

steps:
 1. $oc new-app eap72-basic-s2i
 2. Check the  build and pod
$ oc get builds
NAME        TYPE     FROM          STATUS     STARTED         DURATION
eap-app-1   Source   Git@d76214b   Complete   3 minutes ago   2m59s
$ oc get pods 
NAME               READY   STATUS      RESTARTS   AGE
eap-app-1-build    0/1     Completed   0          5m26s
eap-app-1-deploy   0/1     Completed   0          2m27s
eap-app-1-rwh5q    1/1     Running     0          2m17s

Comment 5 errata-xmlrpc 2019-06-04 10:45:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.