Bug 1688802 - openshift-apiserver clusteroperator unavailable on clean install [NEEDINFO]
Summary: openshift-apiserver clusteroperator unavailable on clean install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Casey Callendrello
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 13:43 UTC by Justin Pierce
Modified: 2019-07-04 09:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 09:01:22 UTC
Target Upstream Version:
xxia: needinfo? (jupierce)


Attachments (Terms of Use)
listings (17.77 KB, text/plain)
2019-03-14 13:43 UTC, Justin Pierce
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:33 UTC

Description Justin Pierce 2019-03-14 13:43:45 UTC
Created attachment 1544075 [details]
listings

Description of problem:
After a clean install of OpenShift 4.0 

Version-Release number of selected component (if applicable):
version   4.0.0-0.alpha-2019-03-14-014544

How reproducible:
Unknown

Steps to Reproduce:
1. Install OCP 4
2. oc get routes

Actual results:
error: the server doesn't have a resource type "routes"

Additional info:
Must-gather info (clusteroperators & csr): http://file.rdu.redhat.com/~jupierce/share/must-gather-openshift-apiserver-unavailable.tgz

See attached listings for oc output

Comment 1 Justin Pierce 2019-03-14 14:01:11 UTC
https://github.com/openshift/origin/pull/22302 is the potential fix.

Comment 2 Maciej Szulik 2019-03-15 12:01:26 UTC
I've just spin up a cluster using 4.0.0-0.alpha-2019-03-15-093013 and it seems just fine. 
If the problem persist, feel free to reopen.

Comment 3 Xingxing Xia 2019-03-18 09:46:27 UTC
Checked above attachment, it included CrashLoopBackOff info due to readiness failure:
$ oc -n openshift-apiserver get all
NAME                  READY   STATUS             RESTARTS   AGE
pod/apiserver-pt7b4   0/1     CrashLoopBackOff   107        9h
pod/apiserver-r7s46   0/1     CrashLoopBackOff   108        9h
pod/apiserver-sx6j4   0/1     CrashLoopBackOff   107        9h

I never hit such failure after in testing fresh installation with builds, no matter including above PR (latest build 4.0.0-0.nightly-2019-03-15-063749) or not. What I hit about the clusteroperator is another issue: cert bug 1688820 (duplicating bug 1688147 / bug 1688503).

Per above PR, it relates to networking. Suggest move this bug to Networking component for better verification.

Comment 4 Xingxing Xia 2019-03-18 09:48:12 UTC
Hmm, let me move it. If wrong, pls correct.

Comment 5 Weibin Liang 2019-03-18 13:32:11 UTC
Testing passed in a new installation with v4.0.0-0.177.0.

[root@dhcp-41-193 openshift-client]# oc get all -n openshift-apiserver
NAME                  READY   STATUS    RESTARTS   AGE
pod/apiserver-dwltt   1/1     Running   0          6m6s
pod/apiserver-mjhlj   1/1     Running   0          5m43s
pod/apiserver-p6sw7   1/1     Running   0          6m56s

NAME          TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)   AGE
service/api   ClusterIP   172.30.114.184   <none>        443/TCP   10m

NAME                       DESIRED   CURRENT   READY   UP-TO-DATE   AVAILABLE   NODE SELECTOR                     AGE
daemonset.apps/apiserver   3         3         3       3            3           node-role.kubernetes.io/master=   10m
[root@dhcp-41-193 openshift-client]# oc version
oc v4.0.0-0.177.0
kubernetes v1.12.4+6a9f178753
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://api.weliang.qe.devcluster.openshift.com:6443
kubernetes v1.12.4+6d3ea30
[root@dhcp-41-193 openshift-client]#

Comment 7 errata-xmlrpc 2019-07-04 09:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.