Bug 1688849 - rpmbuild --sign fails when --quiet is used
Summary: rpmbuild --sign fails when --quiet is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rpm
Version: 8.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 8.0
Assignee: Pavlina Moravcova Varekova
QA Contact: Jan Blazek
Marie Dolezelova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 15:14 UTC by Karel Srot
Modified: 2020-04-22 12:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
.`rpmbuild --sign` is deprecated With this update, the `rpmbuild --sign` command has become deprecated. Using this command in future releases of Red Hat Enterprise Linux can result in an error. It is recommended that you use the `rpmsign` command instead.
Clone Of:
Environment:
Last Closed: 2019-11-05 22:22:32 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3584 None None None 2019-11-05 22:22:59 UTC

Description Karel Srot 2019-03-14 15:14:01 UTC
Description of problem:

I am reporting this despite using rpmbuild --sign is already documented as deprecated.


# rpm -q rpm rpm-sign
rpm-4.14.2-9.el8.x86_64
rpm-sign-4.14.2-9.el8.x86_64

$ rpmbuild --quiet -bb --sign /mnt/tests/CoreOS/rpm/Regression/rpmbuild-ignores-sign-if-quiet-is-used/bz1293483pkg.spec
/sbin/ldconfig: Warning: ignoring configuration file that cannot be opened: rpmsign: no arguments given

while

$ rpmbuild -v -bb --sign /mnt/tests/CoreOS/rpm/Regression/rpmbuild-ignores-sign-if-quiet-is-used/bz1293483pkg.spec
+ umask 022
+ cd /home/bz1293483user/rpmbuild/BUILD
+ touch /tmp/bz1293483pkg.tmp
+ cp /tmp/bz1293483pkg.tmp .
+ exit 0
+ umask 022
+ cd /home/bz1293483user/rpmbuild/BUILD
+ '[' /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64 '!=' / ']'
+ rm -rf /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64
++ dirname /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64
+ mkdir -p /home/bz1293483user/rpmbuild/BUILDROOT
+ mkdir /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64
+ mkdir -p /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64/usr/local/
+ mv bz1293483pkg.tmp /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64/usr/local/
+ /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-ldconfig
/sbin/ldconfig: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf: No such file or directory
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip /usr/bin/strip
+ /usr/lib/rpm/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/brp-python-bytecompile 1
+ /usr/lib/rpm/brp-python-hardlink
+ PYTHON3=/usr/libexec/platform-python
+ /usr/lib/rpm/redhat/brp-mangle-shebangs
+ umask 022
+ cd /home/bz1293483user/rpmbuild/BUILD
+ /usr/bin/rm -rf /home/bz1293483user/rpmbuild/BUILDROOT/bz1293483pkg-1.0-1.x86_64
+ exit 0
/home/bz1293483user/rpmbuild/RPMS/noarch/bz1293483pkg-1.0-1.noarch.rpm:
Enter passphrase: 

built rpm file should be signed even when --quiet option is used.

This is similar although possibly not related to bug 1293483.

Comment 13 errata-xmlrpc 2019-11-05 22:22:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3584


Note You need to log in before you can comment on or make changes to this bug.