Bug 168887 - Suggestion: split kdebase in seperate packages
Suggestion: split kdebase in seperate packages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-20 18:56 EDT by Mephisto
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 15:21:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2005-09-20 18:56:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050915 Fedora/1.5-0.5.0.beta1 Firefox/1.4

Description of problem:
I think it would be nice to split kdebase in seperate packages. There's a lot of programs in this package, and people might only need a part of it, especially when not using kde. I would personally install kcontrol (mainly to change the style on Qt based apps) and maybe kate and konqueror, but i have no need for the rest, since i'm a gnome user.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. install kdebase.
  

Additional info:
Comment 1 Doncho N. Gunchev 2007-06-09 12:46:44 EDT
I would suggest not to. kcontrol + konqueror + kate would require more than 
the half of the kdebase. All other kde packages would have to be changed to 
track this as deps. kdebase is one package upstream.
I'm a KDE user btw.
Comment 2 Rex Dieter 2007-06-19 15:21:58 EDT
WONTFIX (for now), we may reconsider when working on kde4 bits.

Note You need to log in before you can comment on or make changes to this bug.