Bug 1688927 - WIFI is unusable under latest branch and rawhide versions of NetworkManager
Summary: WIFI is unusable under latest branch and rawhide versions of NetworkManager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 30
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-14 18:03 UTC by Bill Gianopoulos
Modified: 2019-09-11 01:30 UTC (History)
12 users (show)

Fixed In Version: NetworkManager-1.20.2-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 01:30:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Bill Gianopoulos 2019-03-14 18:03:12 UTC
Description of problem: I cannot connect to my iPhone hotspot at all using the latest NetworkManager
.  I configured another access point to do wep authentication and this requires me to re-authenticate every 30 seconds.  Downgrading NetworkManger seems to fix the issue.

Comment 1 Bill Gianopoulos 2019-03-14 18:09:56 UTC
I should have mentioned the last version of NetworkManager-wifi I can get to work is 1.16.0-0.1.fc30.

Comment 2 Bill Gianopoulos 2019-03-14 18:22:46 UTC
To make it clear on the fc30 branch downgrading NetworkManager-wifi from version 1.16.0-0.3 to 1.16.0-0.1 corrects the issue.  1.16.0-0.1 is no longer available form the rawhide repositories.

Comment 3 Beniamino Galvani 2019-03-15 08:58:28 UTC
Could you please do the following:

 1. (add '-dd' to OTHER_ARGS in /etc/sysconfig/wpa_supplicant)

 2. systemctl restart wpa_supplicant

 3. journalctl -u wpa_supplicant -u NetworkManager -f > log.txt &

 4. nmcli connection up <name-of-the-hotspot-connection>

   # ^^ this should fail ^^

 5. kill %1

and attach the generated log.txt file? Thanks!

Comment 4 Beniamino Galvani 2019-03-15 09:01:25 UTC
Ah, and please also run 'nmcli general logging level DEBUG' as root as first step.

Comment 5 Thomas Haller 2019-03-15 14:58:22 UTC
can you also show the profile in question?

what gives `nmcli connection show "$PROFILE_NAME"` ?

Comment 7 Bill Gianopoulos 2019-03-15 15:04:50 UTC
(In reply to Beniamino Galvani from comment #4)
> Ah, and please also run 'nmcli general logging level DEBUG' as root as first
> step.

Well I am out of pocket this weekend.  I will try to comply on Monday!

Comment 8 Bill Gianopoulos 2019-03-15 15:06:33 UTC
(In reply to Thomas Haller from comment #5)
> can you also show the profile in question?
> 
> what gives `nmcli connection show "$PROFILE_NAME"` ?

can you see my comment number 7?

Comment 9 Thomas Haller 2019-03-15 16:57:05 UTC
can you test whether 1.16.0-1.fc30 fixes the issue?

Comment 10 Bill Gianopoulos 2019-03-16 20:55:40 UTC
(In reply to Thomas Haller from comment #9)
> can you test whether 1.16.0-1.fc30 fixes the issue?

That works fine for me. does that mean I don;t need to supply any of the debug info you asked for?  I did not ignore the request, just was out of pocket for a couple of days on travel and no access to the laptops that had the issue'

Comment 11 Bill Gianopoulos 2019-03-16 21:03:10 UTC
Oh and I should have mentioned the not able to connect to an iPhone hotspot was kind of a red herring.  I did not realize this never worked on the only machine I tried it on.  I suspect its wifi adapter does not support any of the authentication methods that the iPhone does.

Comment 12 Bill Gianopoulos 2019-03-17 12:13:26 UTC
(In reply to Bill Gianopoulos from comment #11)
> Oh and I should have mentioned the not able to connect to an iPhone hotspot
> was kind of a red herring.  I did not realize this never worked on the only
> machine I tried it on.  I suspect its wifi adapter does not support any of
> the authentication methods that the iPhone does.

I verified that on a different computer system I was able to connect to the iPhone as a hotspot, so if this is a bug is is certainly a different one.  As far as I am concerned this is all fixed by 1.16.0-1.

Comment 13 Pavlo Rudyi 2019-03-19 10:16:03 UTC
I have the same problem with NM 1.16.0-1:

Mar 19 11:20:16 localhost.localdomain NetworkManager[6812]: <info>  [1552987216.4307] manager: NetworkManager state is now DISCONNECTED
Mar 19 11:20:16 localhost.localdomain NetworkManager[6812]: <warn>  [1552987216.4322] device (wlo1): Activation: failed for connection 'MyNetwork'
Mar 19 11:20:16 localhost.localdomain NetworkManager[6812]: <info>  [1552987216.4353] device (wlo1): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Mar 19 11:20:16 localhost.localdomain NetworkManager[6812]: <info>  [1552987216.4524] device (wlo1): set-hw-addr: set MAC address (scanning)
Mar 19 11:20:16 localhost.localdomain gnome-shell[1353]: An active wireless connection, in infrastructure mode, involves no access point?
Mar 19 11:20:16 localhost.localdomain gnome-shell[1353]: Object NM.ActiveConnection (0x556333d26600), has been already deallocated — impossible to get any property from it. This might be caused by the object having been destroyed from C code using something such as destroy(), dispose(), or remove() vfuncs.

Comment 14 Fedora Update System 2019-09-06 07:29:44 UTC
FEDORA-2019-c06f5d9248 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c06f5d9248

Comment 15 Fedora Update System 2019-09-06 10:46:19 UTC
NetworkManager-1.20.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c06f5d9248

Comment 16 Fedora Update System 2019-09-07 15:10:17 UTC
FEDORA-2019-39426d6328 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-39426d6328

Comment 17 Fedora Update System 2019-09-07 16:57:55 UTC
NetworkManager-1.20.2-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-39426d6328

Comment 18 Fedora Update System 2019-09-11 01:30:21 UTC
NetworkManager-1.20.2-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.