Bug 1689041 - Enable service API federation with the example given by kubefed2 cmd failed
Summary: Enable service API federation with the example given by kubefed2 cmd failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Maru Newby
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 02:16 UTC by Qin Ping
Modified: 2019-06-04 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:45:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:45:59 UTC

Description Qin Ping 2019-03-15 02:16:03 UTC
Description of problem:
Enable service API federation with the example given by kubefed2 cmd failed


Version-Release number of selected component (if applicable):
kubefed2 version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}
Federation v2 controller-manager version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

How reproducible:
Always

Steps to Reproduce:
1. The example in kubefed2 help message:
Examples:

  # Enable federation of Services with service type overrideable
  kubefed2 enable Service --override-paths=spec.type --host-cluster-context=cluster1
2. Enable service API fderation with cmd: kubefed2 enable Service --override-paths=spec.type --federation-namespace=federation-llng

Actual results:
Error: unknown flag: --override-paths

Expected results:
If not support --override-paths, we should modify the help message.

Additional info:

Comment 1 Paul Morie 2019-03-18 19:59:38 UTC
Verified that this is an issue in upstream/master: https://github.com/kubernetes-sigs/federation-v2/blob/master/pkg/kubefed2/enable/enable.go#L65

Comment 2 Maru Newby 2019-03-19 03:34:28 UTC
Addressed by https://github.com/kubernetes-sigs/federation-v2/pull/664

Comment 3 Paul Morie 2019-03-29 00:12:24 UTC
Should be fixed in 0.0.7 CSV

Comment 5 Qin Ping 2019-04-01 05:45:40 UTC
Verified with:
kubefed2 version: version.Info{Version:"v0.0.7", GitCommit:"83b778b6d92a7929efb7687d3d3d64bf0b3ad3bc", GitTreeState:"clean", BuildDate:"2019-03-19T18:40:46Z", GoVersion:"go1.11.2", Compiler:"gc", Platform:"linux/amd64"}

Comment 7 errata-xmlrpc 2019-06-04 10:45:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.