Bug 1689055 - libnm crash on `NM.Client.props.dns_configuration`
Summary: libnm crash on `NM.Client.props.dns_configuration`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.1
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1682336
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 03:36 UTC by Gris Ge
Modified: 2019-11-05 22:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:29:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Reproduce script. (325 bytes, text/x-python)
2019-03-15 03:36 UTC, Gris Ge
no flags Details
[PATCH] libnm: fix dns-configuration property type (1.36 KB, patch)
2019-03-15 08:44 UTC, Beniamino Galvani
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3623 None None None 2019-11-05 22:29:56 UTC

Description Gris Ge 2019-03-15 03:36:01 UTC
Created attachment 1544253 [details]
Reproduce script.

Description of problem:


The `nmclient.get_dns_configuration()` works well while `nmclient.props.dns_configuration` cause sigfault.

Version-Release number of selected component (if applicable):
NetworkManager-libnm-1.14.0-14.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run attached python script after installed `python-gobject-base`
2.
3.

Actual results:
Crash

Expected results:

No crash

Additional info:

Comment 1 Beniamino Galvani 2019-03-15 08:44:32 UTC
Created attachment 1544342 [details]
[PATCH] libnm: fix dns-configuration property type

Comment 2 Thomas Haller 2019-03-15 10:11:44 UTC
(In reply to Beniamino Galvani from comment #1)
> Created attachment 1544342 [details]
> [PATCH] libnm: fix dns-configuration property type

lgtm

Comment 10 errata-xmlrpc 2019-11-05 22:29:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3623


Note You need to log in before you can comment on or make changes to this bug.