Bug 1689144 - No puppet agent in rhel 8 tools repository
Summary: No puppet agent in rhel 8 tools repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Released
Assignee: satellite6-bugs
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-15 09:39 UTC by Nikhil Kathole
Modified: 2019-10-07 17:17 UTC (History)
1 user (show)

Fixed In Version: puppet-agent-5.5.0-4.el8sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:40:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:40:36 UTC

Description Nikhil Kathole 2019-03-15 09:39:35 UTC
Description of problem:
There is no puppet packages for rhel 8 clients.


Version-Release number of selected component (if applicable):
Satellite 6.5 snap 19


How reproducible: always


Steps to Reproduce:
1. Register rhel 8 client to satellite
2. yum install puppet-agent

Actual results:
No package puppet-agent.

Expected results:
Puppet should available in rhel 8 tools repo.


Additional info:

Comment 3 Nikhil Kathole 2019-04-01 05:40:55 UTC
VERIFIED

Version tested:
Satellite 6.5 snap 22

# yum install puppet
Updating Subscription Management repositories.
sat6tool8                                                                                                         872  B/s | 2.1 kB     00:02    
Dependencies resolved.
==================================================================================================================================================
 Package                     Arch                  Version                         Repository                                                Size
==================================================================================================================================================
Installing:
 puppet-agent                x86_64                5.5.0-4.el8sat                  Default_Organization_Sat6Tools8_sat6tool8                 20 M
Installing dependencies:
 tar                         x86_64                2:1.30-4.el8                    rhel-base-os                                             838 k

Transaction Summary
==================================================================================================================================================
Install  2 Packages

Total download size: 20 M
Installed size: 91 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): tar-1.30-4.el8.x86_64.rpm                                                                                  263 kB/s | 838 kB     00:03    
(2/2): puppet-agent-5.5.0-4.el8sat.x86_64.rpm                                                                     2.9 MB/s |  20 MB     00:06    
--------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                             3.0 MB/s |  20 MB     00:06     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                          1/1 
  Installing       : tar-2:1.30-4.el8.x86_64                                                                                                  1/2 
  Running scriptlet: tar-2:1.30-4.el8.x86_64                                                                                                  1/2 
  Running scriptlet: puppet-agent-5.5.0-4.el8sat.x86_64                                                                                       2/2 
  Installing       : puppet-agent-5.5.0-4.el8sat.x86_64                                                                                       2/2 
  Running scriptlet: puppet-agent-5.5.0-4.el8sat.x86_64                                                                                       2/2 
  Verifying        : puppet-agent-5.5.0-4.el8sat.x86_64                                                                                       1/2 
  Verifying        : tar-2:1.30-4.el8.x86_64                                                                                                  2/2 
Installed products updated.

Installed:
  puppet-agent-5.5.0-4.el8sat.x86_64                                            tar-2:1.30-4.el8.x86_64                                           

Complete!

Comment 5 errata-xmlrpc 2019-05-14 12:40:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.