Bug 1689194 - Anaconda fails to use inst.repo=hd:<device>:<path> when path is not /
Summary: Anaconda fails to use inst.repo=hd:<device>:<path> when path is not /
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.1
Assignee: Jiri Konecny
QA Contact: Release Test Team
Sharon Moroney
URL:
Whiteboard:
Depends On: 1678953
Blocks: 1701002 1689193
TreeView+ depends on / blocked
 
Reported: 2019-03-15 12:00 UTC by Peter Kotvan
Modified: 2020-11-14 13:44 UTC (History)
7 users (show)

Fixed In Version: anaconda-29.19.1.4-1
Doc Type: Bug Fix
Doc Text:
.The `inst.repo` kernel boot parameter now works for a repository on a hard drive that has a non-root path Previously, the RHEL 8 installation process could not proceed without manual intervention if the `inst.repo=hd:<device>:<path>` kernel boot parameter was pointing to a repository (not an ISO image) on a hard drive, and a non-root (/) path was used. With this update, the installation program can now propagate any `<path>` for a repository located on a hard drive, ensuring the installation proceeds as normal.
Clone Of:
Environment:
Last Closed: 2019-11-05 21:08:45 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
anaconda.log (14.43 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
ifcfg.log (1.65 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
packaging.log (6.21 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
program.log (34.45 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
storage.log (104.11 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
storage.state (24.00 KB, application/octet-stream)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details
syslog (174.61 KB, text/plain)
2019-03-15 12:01 UTC, Peter Kotvan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3417 0 None None None 2019-11-05 21:09:08 UTC

Description Peter Kotvan 2019-03-15 12:00:53 UTC
Description of problem:
Anaconda fails to use inst.repo=hd:<device>:<path> when path is not /.

Version-Release number of selected component (if applicable):
RHEL-8.0.0-RC-2.0 -> RHEL-8.0.0-20190313.0
anaconda-29.19.0.39-1.el8

How reproducible:
always

Steps to Reproduce:
1. Mount the installation ISO and copy the contents to a partition so that the content is not in the / of that partition.
2. Start another installation with inst.repo=hd:<device>:<path> (e.g. inst.repo=hd:vdb1:/iso-content)
3. Anaconda cannot use the installation source.

Actual results:
Anaconda fails to use inst.repo=hd:<device>:<path> when path is not /.

Expected results:
inst.repo=hd:<device>:<path> when path is not / is usable as an installation source in anaconda.

Additional info:

Comment 1 Peter Kotvan 2019-03-15 12:01:39 UTC
Created attachment 1544428 [details]
anaconda.log

Comment 2 Peter Kotvan 2019-03-15 12:01:42 UTC
Created attachment 1544429 [details]
ifcfg.log

Comment 3 Peter Kotvan 2019-03-15 12:01:44 UTC
Created attachment 1544430 [details]
packaging.log

Comment 4 Peter Kotvan 2019-03-15 12:01:47 UTC
Created attachment 1544431 [details]
program.log

Comment 5 Peter Kotvan 2019-03-15 12:01:50 UTC
Created attachment 1544432 [details]
storage.log

Comment 6 Peter Kotvan 2019-03-15 12:01:53 UTC
Created attachment 1544433 [details]
storage.state

Comment 7 Peter Kotvan 2019-03-15 12:01:56 UTC
Created attachment 1544434 [details]
syslog

Comment 9 Jiri Konecny 2019-05-30 13:09:17 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1985

Comment 19 errata-xmlrpc 2019-11-05 21:08:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3417


Note You need to log in before you can comment on or make changes to this bug.