Bug 168930 - oprofile.ko needs unknown symbols
Summary: oprofile.ko needs unknown symbols
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
medium
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-21 12:37 UTC by Frank Arnold
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.13-1.1580_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 20:46:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Arnold 2005-09-21 12:37:35 UTC
Description of problem:

When a kernel gets installed on the system I see following warnings:
WARNING: /lib/modules/2.6.13-1.1565_FC5/kernel/arch/ppc/oprofile/oprofile.ko
needs unknown symbol request_perfmon_irq
WARNING: /lib/modules/2.6.13-1.1565_FC5/kernel/arch/ppc/oprofile/oprofile.ko
needs unknown symbol free_perfmon_irq 

include/asm-ppc/perfmon.h contains these symbols, but with my poor C knowledge I
can't figure out what's wrong here. It doesn't bother me anyway. Just want to
make sure it gets mentioned somewhere, because I'm seeing this for several
versions now. 

Version-Release number of selected component (if applicable):
IIRC 2.6.13-1.1565_FC5, 2.6.13-1.1561_FC5, 2.6.13-1.1558_FC5

Comment 1 Frank Arnold 2005-09-28 20:46:38 UTC
Didn't appear anymore. A patch for perfmon.c by BenH was committed 5 days ago,
and a fix for this patch 5 hours ago. I assume that it's fixed now.


Note You need to log in before you can comment on or make changes to this bug.