Bug 1689591 - RFE: Add support for passing a gpgkey file path to --repofrompath
Summary: RFE: Add support for passing a gpgkey file path to --repofrompath
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: dnf-community
TreeView+ depends on / blocked
 
Reported: 2019-03-16 20:55 UTC by Neal Gompa
Modified: 2019-03-31 03:00 UTC (History)
9 users (show)

Fixed In Version: dnf-4.2.2-1.fc30 dnf-4.2.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-31 00:04:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github juanluisbaptiste docker-brew-mageia issues 12 None None None 2019-03-16 20:55:54 UTC

Description Neal Gompa 2019-03-16 20:55:28 UTC
Description of problem:
When trying to produce Mageia containers for alternative architectures, we need to use repos using --repofrompath. However, since --repofrompath doesn't have an optional third argument for setting gpgkey file path, installs fail because it can't verify package signatures.

Version-Release number of selected component (if applicable):
4.2.1-1.fc31

How reproducible:
Always

Steps to Reproduce:
1. Clone https://github.com/juanluisbaptiste/docker-brew-mageia
2. Run mkimage-dnf.sh --rootfs=/code/6/ --version=6 -a armv7hl --mirror=http://distro.ibiblio.org/pub/linux/distributions/mageia/distrib/6/armv7hl

Actual results:
Installation fails due to being unable to validate signatures

Expected results:
--repofrompath takes three parameters, and the last one is the gpgkey, and makes it so that it can validate and install successfully.

Comment 1 Jaroslav Mracek 2019-03-19 11:45:49 UTC
I created a patch (https://github.com/rpm-software-management/dnf/pull/1357) that allows adjustments of configurations using --setopt=<repo>.<option>=value syntax.

Comment 2 Fedora Update System 2019-03-27 13:37:19 UTC
dnf-4.2.2-1.fc30 librepo-1.9.6-1.fc30 libdnf-0.28.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b504d6ad8f

Comment 3 Fedora Update System 2019-03-27 13:37:43 UTC
dnf-4.2.2-1.fc29 librepo-1.9.6-1.fc29 libdnf-0.28.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7fbfa37585

Comment 4 Fedora Update System 2019-03-27 18:18:25 UTC
dnf-4.2.2-1.fc30, libdnf-0.28.1-1.fc30, librepo-1.9.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b504d6ad8f

Comment 5 Fedora Update System 2019-03-27 20:01:55 UTC
dnf-4.2.2-1.fc29, libdnf-0.28.1-1.fc29, librepo-1.9.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7fbfa37585

Comment 6 Fedora Update System 2019-03-31 00:04:08 UTC
dnf-4.2.2-1.fc30, libdnf-0.28.1-1.fc30, librepo-1.9.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-03-31 03:00:45 UTC
dnf-4.2.2-1.fc29, libdnf-0.28.1-1.fc29, librepo-1.9.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.