Bug 168969 - Nfs server very slow
Nfs server very slow
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 15:01 EDT by Marc Andre Luthi
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-08 08:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Andre Luthi 2005-09-21 15:01:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
I export a raid directory with nfs. I mount the share on the local machine or an other host. I copy 160Mb in about 90s. a normal value is 15..30s. There is no error log somewhere. If I export in async mode It copy in 5s + 12s for the sync command on the server so it should take about 17s and not 90s. Same result without raid (just a disk).

I tested with a debian and kernel 2.6.13.1 and 2.4 it's the same. Debian also provide a user space nfs server. It's then take about 18s.


I tried to update to your last kernel but then I have a kernel panic.

Local copy on the exported directory take about "time  cp -av /opt/usr /mnt/sdb1/usr5 ; time sync"  15s




Installation on a dual Intel(R) Xeon(TM) CPU 3.40GHz with a  RAID bus controller: LSI Logic / Symbios Logic MegaRAID (rev 07). all info for hardware at https://rhn.redhat.com/network/systems/details/hardware.pxt?sid=1005916035






Version-Release number of selected component (if applicable):
kernel-utils-2.4-13.1.66.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.echo "/mnt/sdb1       xxx.xx.xx(rw,no_root_squash,sync,insecure)" >/etc/exports
2.service nfs restart
3.mount xxx.xx.xx:/mnt/sdb1 /mnt/test
4.time cp -av /opt/160MB-dir /mnt/test
  

Actual Results:  time is about 90s

Expected Results:  about 18s

Additional info:

I can not update to the latest kernel as the kernel panic
Comment 3 Marc Andre Luthi 2005-10-06 08:23:19 EDT
Problem solved. The scsi disks are incompatible with the back-plane.
I used 5 Seagate disk and all of them add problem. With Maxtor disk it work fine.

It's a strange behavior as the disk are fine under Windows (all test done). It's
also not a problem with the back plane as I tested with other back plane (4
diff.). It's also not an raid card problem as i changed to std 29160 and the
problem was not solved.  

Note You need to log in before you can comment on or make changes to this bug.