Bug 1689750 - VBoxService stops with error VERR_VERSION_MISMATCH if VirtualBox server is version 6.0.4
Summary: VBoxService stops with error VERR_VERSION_MISMATCH if VirtualBox server is ve...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virtualbox-guest-additions
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-18 02:24 UTC by Sergio Monteiro Basto
Modified: 2019-04-01 11:20 UTC (History)
3 users (show)

Fixed In Version: virtualbox-guest-additions-6.0.4-2.fc29 virtualbox-guest-additions-6.0.4-2.fc28 virtualbox-guest-additions-6.0.4-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 06:05:19 UTC


Attachments (Terms of Use)
journalctl -u vboxservice.service (25.57 KB, text/plain)
2019-03-18 02:24 UTC, Sergio Monteiro Basto
no flags Details

Description Sergio Monteiro Basto 2019-03-18 02:24:32 UTC
Created attachment 1545056 [details]
journalctl -u vboxservice.service

Description of problem:

After upgrade my VirtualBox host to 6.0.4, VBoxService on guest stops to work , time synchronization stops, shared folder also stops , only vboxvideo still working .

Building virtualbox-guest-additions in old way with kmods from VirtualBox source and adding binary mount.vboxsf.
Also I had to hack fedora kernel and delete staging vbox*.ko , install new kmods run depmod and finally I could verify guest-additions works as expect . 

Of course I don't know how is fixed  , hopefully I didn't update virtualbox-server in stable branches .

Comment 1 Fedora Update System 2019-03-20 09:25:04 UTC
virtualbox-guest-additions-6.0.4-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-97610b52ff

Comment 2 Fedora Update System 2019-03-20 09:25:12 UTC
virtualbox-guest-additions-6.0.4-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-90d0665c95

Comment 3 Fedora Update System 2019-03-20 09:25:20 UTC
virtualbox-guest-additions-6.0.4-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d90f21bd4b

Comment 4 Hans de Goede 2019-03-20 09:40:26 UTC
Hi,

Thank you for the bug report.

So there are 2 issues involved here:

1) When running virtualbox-guest-additions-6.0.x on a 6.0.x host, vboxservice.service will fail to start with a VERR_VERSION_MISMATCH error
This is caused by the mainline kernel version of vboxguest missing a new vboxguest feature which is used by the 6.0.x extensions on a 6.0.x host.

I've prepared a kernel-patch for this and submitted it upstream. I will also add this patch to the Fedora kernels, so that it will get picked up with the next official Fedora kernel build.

2) virtualbox-guest-additions now has 2 seperate code-paths for auto-mounting shared folders, one for when running on a 5.x.x host and for when running on a 6.0.x host. This means that 0001-VBoxServiceAutoMount-Change-Linux-mount-code-to-use-.patch needed updating to also cover the new 6.0.x host paths. I've prepared a set of virtualbox-guest-additions updates fixing this, these should show up in updates-testing with the next push.

Regards,

Hans

Comment 5 Hans de Goede 2019-03-20 11:54:36 UTC
Note the kernel changes also require some changes to the vboxsf driver (currently in rpmfusion) for it to build against kernels with these changes.

These changes are available here:
https://github.com/jwrdegoede/vboxsf/

I've implemented them in such a way that that code will build against both the old and new mainline-kernel vboxguest APIs.

I'm still working on getting vboxsf merged upstream.

Comment 6 Fedora Update System 2019-03-20 22:02:32 UTC
virtualbox-guest-additions-6.0.4-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-90d0665c95

Comment 7 Fedora Update System 2019-03-20 22:18:12 UTC
virtualbox-guest-additions-6.0.4-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d90f21bd4b

Comment 8 Fedora Update System 2019-03-21 19:12:07 UTC
virtualbox-guest-additions-6.0.4-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-97610b52ff

Comment 9 Fedora Update System 2019-03-25 06:05:19 UTC
virtualbox-guest-additions-6.0.4-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-03-26 16:14:52 UTC
kernel-tools-5.0.4-300.fc30 kernel-headers-5.0.4-300.fc30 kernel-5.0.4-300.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e7590b99c

Comment 11 Fedora Update System 2019-03-26 16:16:31 UTC
kernel-tools-5.0.4-200.fc29 kernel-headers-5.0.4-200.fc29 kernel-5.0.4-200.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0ba1e6642f

Comment 12 Fedora Update System 2019-03-27 00:45:25 UTC
kernel-5.0.4-300.fc30, kernel-headers-5.0.4-300.fc30, kernel-tools-5.0.4-300.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e7590b99c

Comment 13 Fedora Update System 2019-03-27 04:34:41 UTC
kernel-5.0.4-200.fc29, kernel-headers-5.0.4-200.fc29, kernel-tools-5.0.4-200.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0ba1e6642f

Comment 14 Fedora Update System 2019-03-29 02:04:06 UTC
virtualbox-guest-additions-6.0.4-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-03-29 02:59:05 UTC
kernel-5.0.4-200.fc29, kernel-headers-5.0.4-200.fc29, kernel-tools-5.0.4-200.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-03-29 19:18:34 UTC
virtualbox-guest-additions-6.0.4-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-03-31 00:03:58 UTC
kernel-5.0.4-300.fc30, kernel-headers-5.0.4-300.fc30, kernel-tools-5.0.4-300.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Sergio Monteiro Basto 2019-03-31 01:23:12 UTC
BTW I just finish my tests and is working well and without any problem [1] 

Should I be concerned with [drm] VirtualBox host is too old, no cursor support ? 

[1]
[    0.000000] DMI: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
[    0.128264] ACPI: RSDP 0x00000000000E0000 000024 (v02 VBOX  )
[    0.128268] ACPI: XSDT 0x0000000076AF0030 00003C (v01 VBOX   VBOXXSDT 00000001 ASL  00000061)
[    0.128275] ACPI: FACP 0x0000000076AF00F0 0000F4 (v04 VBOX   VBOXFACP 00000001 ASL  00000061)
[    0.128282] ACPI: DSDT 0x0000000076AF0470 0022EA (v02 VBOX   VBOXBIOS 00000002 INTL 20181213)
[    0.128293] ACPI: APIC 0x0000000076AF0240 00005C (v02 VBOX   VBOXAPIC 00000001 ASL  00000061)
[    0.128297] ACPI: SSDT 0x0000000076AF02A0 0001CC (v01 VBOX   VBOXCPUT 00000002 INTL 20181213)
[    1.432883] ata2.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/133
[    1.764982] ata1.00: ATA-6: VBOX HARDDISK, 1.0, max UDMA/133
[    1.765782] scsi 0:0:0:0: Direct-Access     ATA      VBOX HARDDISK    1.0  PQ: 0 ANSI: 5
[    1.768016] scsi 1:0:0:0: CD-ROM            VBOX     CD-ROM           1.0  PQ: 0 ANSI: 5
[    2.068535] vboxguest: host-version: 6.0.4r128164 0x80000007
[    2.070226] input: VirtualBox mouse integration as /devices/pci0000:00/0000:00:04.0/input/input5
[    2.081139] vboxguest: misc device minor 57, IRQ 20, I/O port d020, MMIO at 0x00000000f0400000 (size 0x0000000000400000)
[    3.108962] vboxvideo: module is from the staging directory, the quality is unknown, you have been warned.
[    3.110947] [drm] VirtualBox host is too old, no cursor support
               ^^^^

[    3.114733] fbcon: vboxdrmfb (fb0) is primary device
[    3.136294] vboxvideo 0000:00:02.0: fb0: vboxdrmfb frame buffer device
[    3.141923] [drm] Initialized vboxvideo 1.0.0 20130823 for 0000:00:02.0 on minor 0
[  192.391318] vboxsf: loading out-of-tree module taints kernel.
[  192.391438] vboxsf: module verification failed: signature and/or required key missing - tainting kernel

Comment 19 Hans de Goede 2019-04-01 11:20:34 UTC
(In reply to Sergio Monteiro Basto from comment #18)
> BTW I just finish my tests and is working well and without any problem [1] 
> 
> Should I be concerned with [drm] VirtualBox host is too old, no cursor
> support ? 

That should not happen, but if you are not seeing any negative side-effects I would not worry about it. I cannot reproduce this myself using a 6.0.x host with the very latest kernelcode, I guess this might be a bug in the version of the vboxvideo code used in your kernel which is fixed in the latest version of the vboxvideo code.


Note You need to log in before you can comment on or make changes to this bug.