Bug 168979 - Can't add -y to /fsckoptions
Summary: Can't add -y to /fsckoptions
Status: CLOSED DUPLICATE of bug 143351
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-21 19:51 UTC by Bill Nottingham
Modified: 2014-03-17 02:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 21:43:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2005-09-21 19:51:37 UTC
+++ This bug was initially created as a clone of Bug #154765 +++

Description of problem:
rc.sysinit does not support fully automatic filesystem checking (fsck -y)

Version-Release number of selected component (if applicable):
initscripts-7.93.11.EL-1

How reproducible:
always

Steps to Reproduce:
1. echo "-y" > /fsckoptions
2. reboot
  
Actual results:
after reboot root filesystem check fails due to conflicting switches
given to fsck: fsck -a -y

Expected results:
system should boot up normally, doing filesystem checks with fsck -y
instead of fsck -a

Additional info:
easy workaround is to edit /etc/rc.d/rc.sysedit manually, and replace
all occurences of 'fsck -T -a ...' with 'fsck -T -y ...'

Comment 1 Bill Nottingham 2005-10-03 21:43:45 UTC

*** This bug has been marked as a duplicate of 143351 ***


Note You need to log in before you can comment on or make changes to this bug.