Bug 1689819 - AtomicHost 20190315 ppc64le install failure: VFS: Cannot open root device "(null)" ... error -6 [NEEDINFO]
Summary: AtomicHost 20190315 ppc64le install failure: VFS: Cannot open root device "(n...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 29
Hardware: powerpc
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2019-03-18 08:40 UTC by Michel Normand
Modified: 2019-03-18 17:50 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-03-18 17:50:43 UTC
pjones: needinfo? (normand)


Attachments (Terms of Use)
atomichost_cannot_open_root_device.png (292.90 KB, image/png)
2019-03-18 08:40 UTC, Michel Normand
no flags Details

Description Michel Normand 2019-03-18 08:40:00 UTC
Created attachment 1545132 [details]
atomichost_cannot_open_root_device.png

AtomicHost 20190315 ppc64le install failure: VFS: Cannot open root device "(null)" ... error -6

as per attached image atomichost_cannot_open_root_device.png

problem reported by local ppc64le openQA test with compose 20190315
https://kojipkgs.fedoraproject.org/compose/updates/Fedora-29-updates-20190315.0/compose/AtomicHost/ppc64le/iso/Fedora-AtomicHost-ostree-ppc64le-29-20190315.0.iso

No such problem with previous compose 20190314
https://kojipkgs.fedoraproject.org/compose/updates/Fedora-29-updates-20190314.0/compose/AtomicHost/ppc64le/iso/Fedora-AtomicHost-ostree-ppc64le-29-20190314.0.iso

I assume this is an iso build problem.

Comment 1 Brian Lane 2019-03-18 16:17:39 UTC
I'm not sure what's going on here. f29-branch hasn't changed since 2/28 and the root argument is still set to an empty string (unlike f30 and rawhide).
This error usually means the iso label doesn't match the root line, but on ppc64 we don't set it explicitly so grub2 is supposed to figure it out.

Both of these builds are using the same lorax version according to pylorax.log: version is 29.26-1

So whatever changed wasn't lorax. Moving it to grub2 since that's the bootloader used on the ppc64le iso.

Comment 2 Peter Jones 2019-03-18 17:23:06 UTC
Can you show us what the kernel command line options were in the bootloader?

Comment 3 Michel Normand 2019-03-18 17:50:43 UTC
I apologize for your investigation time :(
As you pointed out the failure was caused by a bad command line option passed to bootloader.
This was caused by an openQA script I locally modified that removed the boot option.

I am closing this bug as user error (worksforme)

Sorry again.


Note You need to log in before you can comment on or make changes to this bug.