Bug 168986 - Files disappear from nfs shares
Files disappear from nfs shares
Status: CLOSED DUPLICATE of bug 158293
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 16:39 EDT by Glen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:20:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen 2005-09-21 16:39:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Description of problem:
I've switched a couple nfs servers over to Red Hat Enterprise Linux 4, and now I've been noticing some strangeness.  At first I figured it was my older Fedora clients, but I get the same thing when I use RHEL 4 as the client.

What happens is that files seem to up and disappear from directories every so often.  For example I might type "ls", and it spits back the message "ls: .:No such file or directory", or some times a similar error for a file that resides in that directory.  Then, if I wait a few minutes ls lists the files as normal.

If it's any help, here's what an /etc/exports entry will typically look like:
/export/home/foo @trusted-servers(rw,no_root_squash,sync) @suspect-servers(rw,sync)

And here are the options I'm passing to the mount command on my clients:
-rw,bg,hard,intr,rsize=8192,wsize=8192

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-11.EL

How reproducible:
Sometimes

Steps to Reproduce:
1. Run ls in a directory inside an nfs share
2.
3.
  

Actual Results:  Sometimes ls acts strangely.

Expected Results:  I'd expect ls to just list files as normal.

Additional info:
Comment 2 Stephen Tweedie 2005-09-21 17:20:56 EDT
This is almost certainly an instance of a problem already found and fixed; the
fix will be released as part of the U2 kernel.  Please reopen if the U2 kernel
does not solve the problem.

The patch we are using to fix this problem is attached to bug 150759.  For
reference, you can find it directly at the url

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=114644



*** This bug has been marked as a duplicate of 158293 ***

Note You need to log in before you can comment on or make changes to this bug.