Bug 1689909 - Switch to a string for RPM calls
Summary: Switch to a string for RPM calls
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Vendula Poncova
QA Contact: Release Test Team
Sharon Moroney
URL:
Whiteboard:
: 1689182 (view as bug list)
Depends On:
Blocks: 1701002 1631292 1715212
TreeView+ depends on / blocked
 
Reported: 2019-03-18 12:24 UTC by Tomas Mlcoch
Modified: 2020-11-14 15:00 UTC (History)
13 users (show)

Fixed In Version: anaconda-29.19.1.3-1
Doc Type: Bug Fix
Doc Text:
.The RHEL 8 installation program now handles strings from RPM Previously, when the `python3-rpm` library returned a string, the installation program failed with an exception. With this update, the installation program can now handle strings from RPM.
Clone Of:
Environment:
Last Closed: 2019-11-05 21:08:45 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the failure (132.99 KB, image/jpeg)
2019-03-18 12:24 UTC, Tomas Mlcoch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3417 0 None None None 2019-11-05 21:09:08 UTC

Description Tomas Mlcoch 2019-03-18 12:24:35 UTC
Created attachment 1545200 [details]
Screenshot of the failure

Description of problem:
Image build tasks in RHEL-8.1.0 compose are failing:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=20646318
E.g. x86_64 task:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=20646332
See screenshot for whole traceback.
This is blocking 8.1.0 composes.

Version-Release number of selected component (if applicable):
$ brew latest-build rhel-8.1.0-build anaconda
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
anaconda-29.19.0.40-1.el8                 rhel-8.0.0-candidate  rvykydal

How reproducible:
Always

Steps to Reproduce:
1. Run image build in rhel-8.1.0 buildroot

Actual results:
Installation fails

Expected results:
Installation is successful

Comment 7 Jiri Konecny 2019-03-20 09:00:41 UTC
*** Bug 1689182 has been marked as a duplicate of this bug. ***

Comment 10 Tomas Mlcoch 2019-03-22 06:46:14 UTC
Jirko, could Anaconda team take a look? It seems to be really a bug in Anaconda that must be fixed in reasonable as it's breaking 8.1.0 composes :(

Comment 19 Petr Janda 2019-04-09 14:07:48 UTC
granting qa_ack as I  was able to reproduce it with rpm-4.14.2-10.el8 and anaconda 29.19.0.41-1.el8_0 (RHEL-8.1.0-20190409.n.0)

Comment 22 Vendula Poncova 2019-04-16 15:59:38 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1950

Comment 30 errata-xmlrpc 2019-11-05 21:08:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3417


Note You need to log in before you can comment on or make changes to this bug.