This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 169007 - Package glpk-utils-4.8-3 requires GLIBC_2.4
Package glpk-utils-4.8-3 requires GLIBC_2.4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glpk (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 22:32 EDT by Geraldo Veiga
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.8-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 11:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Geraldo Veiga 2005-09-21 22:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
glpk-utils-4.8-3.i386.rpm requires a non-available version of libc.

Here is the message during installation or executions (if installed with --nodeps):

glpsol: /lib/libc.so.6: version `GLIBC_2.4' not found (required by glpsol)



Version-Release number of selected component (if applicable):
glpk-utils-4.8-3

How reproducible:
Always

Steps to Reproduce:
1.rpm --install --nodeps glpk-utils-4.8-3.i386.rpm glpk-devel-4.8-3.i386.rpm
2. execute glpsol
3.
  

Actual Results:  glpsol: /lib/libc.so.6: version `GLIBC_2.4' not found (required by glpsol)

Additional info:
Comment 1 Quentin Spencer 2005-09-22 09:38:01 EDT
You didn't give details, but I assume you're trying to install glpk from Fedora
development on Fedora Core 4? Development RPMs can't always be expected to be
binary compatible with FC4. Before now, GLPK was only in the development branch,
but I am in the process of adding it to FC4 Extras. I will put a message here
when it is released. If you need glpk-utils for FC4 immediately, I suggest
downloading the source RPM and rebuilding it for your system.
Comment 2 Quentin Spencer 2005-09-26 11:41:56 EDT
glpk has now been added to FC-4, and the newly released version 4.8-3 should not
have this problem.
Comment 3 Geraldo Veiga 2005-09-26 17:01:10 EDT
Great.  Many thanks. I installed with yum from the Extras repository. It works!!!

Note You need to log in before you can comment on or make changes to this bug.