Bug 169008 - resume install on previous failure
resume install on previous failure
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-21 23:21 EDT by sanjeev
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 15:31:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sanjeev 2005-09-21 23:21:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Fedora has tons of packages to install and when installing most of them..
if installer crashes with an error, its almost a pain to redo the whole process
and ofcourse lots of time waste. Can there be a Installing Resumer which actually
resumes the install from where it had crashed earlier. May be saving the
installed packages image and checking for it while next reboot and trying to 
resume it..


This will greatly help.
__
Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. On every install failure
2.
3.
  

Additional info:
Comment 1 Rahul Sundaram 2005-11-17 08:04:08 EST

Bumping up to devel. This feature is one of the planned enhancements

http://fedoraproject.org/wiki/AnacondaWorkItems
Comment 2 Jeremy Katz 2006-01-31 15:31:53 EST
Handling this is very difficult as you could have failed at any of a number of
points leaving your filesystem in a very inconsistent state.
Comment 3 sanjeev 2006-01-31 22:24:55 EST
(In reply to comment #2)
> Handling this is very difficult as you could have failed at any of a number of
> points leaving your filesystem in a very inconsistent state.

May be handling some points can be done...
Like storing the pre-install steps like, mounting info,
network, firewall, etc info, selected packages info.. etc 
somewhere if formatting of partitions step is successfull..
(may be in the root partition.. as anyhow.. the installer will
check for whether to install or upgrade the existing OS based
on the presence of a root partition).

Once the install of rpms started... and if the 
system level rpms' like glibc etc are installed
successfully, may be we can save the so far installed
rpms list (which i think is already done) and on
the error reboot, try to diff from the user selected
list and start from the next rpm.. to be installed...
It is like.. sometimes.. an rpm install is failing..
because of corrupt? may be and the installer is
refusing to go to next rpm and exiting.. i feel 
that would help...

Just ideas to share..
__
thanks

Note You need to log in before you can comment on or make changes to this bug.