Bug 169013 - R cannot open X windows due to missing font
R cannot open X windows due to missing font
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 03:10 EDT by Joe Burks
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 11:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Burks 2005-09-22 03:10:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Any attempt to get R to open an X windows fails.  This may be due to a missed dependency, but I've installed every fontpack I could think of and the problem doesn't go away.

Version-Release number of selected component (if applicable):
R-2.1.1-2.fc4

How reproducible:
Always

Steps to Reproduce:
1. Start R
2. s <- c(1,2,3)
3. plot(s)
  

Actual Results:  can't find X11 font
Error in X11(display, width, height, pointsize, gamma, colortype, maxcubesize, :
        unable to start device X11

Expected Results:  Should have opened a window and plotted a very straight line.

Additional info:
Comment 1 Tom "spot" Callaway 2005-09-22 11:36:03 EDT
I can't reproduce this one on my FC3 (ppc) or FC5 (x86) machines.

I've got these font packages installed (rpm -qa |grep font) on my FC3 machine:

fonts-xorg-base
fonts-xorg-75dpi
fonts-xorg-100dpi
fonts-japanese
xorg-x11-font-utils
urw-fonts
ghostscript-fonts
chkfontpath
bitstream-vera-fonts
tetex-fonts
fontconfig
bitmap-fonts
fontconfig-devel

How is your system different?
Comment 2 Joe Burks 2005-09-22 15:32:17 EDT
I'm currently running FC4.  Here's my font list:

[root@open-226-187 ~]# rpm -qa |grep font
fontconfig-devel-2.2.3-13
mathml-fonts-1.0-18.fc4
fontconfig-2.2.3-13
fonts-xorg-100dpi-6.8.2-1
urw-fonts-2.3-1
xorg-x11-font-utils-6.8.2-37.FC4.48.1
ghostscript-fonts-5.50-13
fonts-xorg-base-6.8.2-1
fonts-xorg-truetype-6.8.2-1
fonts-xorg-75dpi-6.8.2-1
fonts-japanese-0.20050222-3
chkfontpath-1.10.0-4
bitstream-vera-fonts-1.10-5
bitmap-fonts-0.3-4
tetex-fonts-3.0-6.FC4

I didn't have the fonts-japanese installed before, but I went ahead and
installed them and get the same thing:

[root@open-226-187 ~]# R

R : Copyright 2005, The R Foundation for Statistical Computing
Version 2.1.1  (2005-06-20), ISBN 3-900051-07-0

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for a HTML browser interface to help.
Type 'q()' to quit R.

> s <- c(1,2,3)
> plot(s)
can't find X11 font
Error in X11(display, width, height, pointsize, gamma, colortype, maxcubesize, 
:
        unable to start device X11
>

I will test this on a completely fresh FC4 install tonight to see if maybe it is
something I have done or if I can recreate it with a very simple setup.
Comment 3 Joe Burks 2005-09-23 22:05:14 EDT
I've tried to repeat this problem with a fresh FC4 install on another machine
and couldn't reproduce it (works fine on the other machine).  Something seems
unique about my laptop install that is preventing R from running properly but I
don't know what yet.  Until I figure it out, I guess this bug can be closed.
Comment 4 Joe Burks 2005-09-24 22:39:14 EDT
I found the problem, it's on my end.  I installed nvidia's X driver and
apparently R and the "nvidia" driver don't mesh.  Switching back to the "nv"
driver fixes all the problems with R.
Comment 5 Tom "spot" Callaway 2006-04-07 11:35:09 EDT
Closing this out.

Note You need to log in before you can comment on or make changes to this bug.