Bug 169015 - Rebuild required
Rebuild required
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-BerkeleyDB (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 03:17 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 15:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-09-22 03:17:00 EDT
perl-BerkeleyDB is fairly unusable right now due to the fact that a newer
version of db4 has been built in rawhide.  The current RPM of perl-BerkeleyDB
was built against this older version 4.3.27, and needs a rebuild for the newer
4.3.28.

For example, with amavisd we see this:

[root@tornado linux-2.6]# /etc/init.d/amavisd restart
Stopping amavisd: [FAILED]
Starting amavisd: Problem in Amavis::DB or Amavis::DB::SNMP code: 
BerkeleyDB needs compatible versions of libdb & db.h
        you have db.h version 4.3.27 and libdb version 4.3.28
Compilation failed in require at (eval 37) line 12.
BEGIN failed--compilation aborted at (eval 37) line 12.
[FAILED]
[root@tornado linux-2.6]#

[A rebuild of perl-BerkeleyDB fixed the problem for me locally, but this needs
to be done in the -extras repo]
Comment 1 Steven Pritchard 2005-09-24 15:22:18 EDT
Can someone explain to me why a minor version change is breaking compatibility?

In any case, I've requested a rebuild.

Note You need to log in before you can comment on or make changes to this bug.