Bug 1690319 - federation-controller-manager needs to use imagePullPolicy "IfNotPresent"
Summary: federation-controller-manager needs to use imagePullPolicy "IfNotPresent"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-19 09:49 UTC by Qin Ping
Modified: 2019-06-04 10:46 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:15 UTC

Description Qin Ping 2019-03-19 09:49:53 UTC
Description of problem:
federation-controller-manager needs to use imagePullPolicy "IfNotPresent"

Version-Release number of selected component (if applicable):
kubefed2 version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

Federation v2 controller-manager version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-15-063749   True        False         3h32m   Cluster version is 4.0.0-0.nightly-2019-03-15-063749



How reproducible:
100%


Steps to Reproduce:
1. install federationv2 control plane with operatorhub
2. check federationv2 control plane pod image pull policy


Actual results:
$ oc get pod federation-controller-manager-5bf69f77f7-4gw7w -oyaml|grep image: -A 1
    image: quay.io/openshift/origin-federation-controller:v4.0.0
    imagePullPolicy: Always


Expected results:
The image pull policy should be "IfNotPresent"

Additional info:

Comment 1 Paul Morie 2019-03-29 00:10:54 UTC
Should be fixed in 0.0.7 CSV

Comment 3 Qin Ping 2019-04-01 05:02:31 UTC
Verified with:
$ oc get clusterversion
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.ci-2019-03-31-223338   True        False         91m       Cluster version is 4.0.0-0.ci-2019-03-31-223338

Federation v2 controller-manager version: version.Info{Version:"v0.0.7", GitCommit:"3e251608ca5357080b95a0bedc45759652f17d29", GitTreeState:"clean", BuildDate:"2019-03-22T22:30:26Z", GoVersion:"go1.11.2", Compiler:"gc", Platform:"linux/amd64"}


$ oc get pod federation-controller-manager-7ccc559cdd-rmw2h -n federation-system -ojson|jq .spec.containers[].imagePullPolicy
"IfNotPresent"

Comment 5 errata-xmlrpc 2019-06-04 10:46:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.