Bug 1690429 - sometimes icon not showing for eg firefox in gnome-shell overview dash
Summary: sometimes icon not showing for eg firefox in gnome-shell overview dash
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell   
(Show other bugs)
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlock...
Keywords: CommonBugs
: 1689692 1691486 (view as bug list)
Depends On:
Blocks: BetaFreezeException, F30BetaFreezeException F30FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-19 13:18 UTC by Jens Petersen
Modified: 2019-04-21 20:32 UTC (History)
26 users (show)

Fixed In Version: gnome-shell-3.32.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-04-21 20:32:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot of the issue (272.67 KB, image/png)
2019-03-20 15:31 UTC, Alessio
no flags Details
screenshot of bug (873.15 KB, image/png)
2019-03-20 22:05 UTC, Geoffrey Marr
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-shell/issues/1053 None None None 2019-04-09 00:08 UTC

Description Jens Petersen 2019-03-19 13:18:00 UTC
Description of problem:
There seems to be a problem with icons in app dash on the left
side of the overview. Sometimes icons do not appear in the dash,
just a little vertical space.

Version-Release number of selected component (if applicable):
gnome-shell-3.32.0-1.fc30
Fedora-Workstation-Live-x86_64-30-20190318.n.0.iso

How reproducible:
50%?

Steps to Reproduce:
1. boot Fedora-Workstation-Live-x86_64-30-20190318.n.0.iso downloaded from Koji
2. try to launch firefox from Dash

Actual results:
Firefox icon is not shown (at the top of the dash),
just a small dark horizontal bar.


Expected results:
Firefox icon to appear

Additional info:
Workaround seems to be to add another app to the dash, and then move
the firefox icon and it appears, or such actions.

Comment 1 Fedora Blocker Bugs Application 2019-03-20 15:25:09 UTC
Proposed as a Freeze Exception for 30-beta by Fedora user jlanda using the blocker tracking app because:

 Goes against final criteria and can't be fixed on the live ;)

Comment 2 Fedora Blocker Bugs Application 2019-03-20 15:27:33 UTC
Proposed as a Blocker for 30-final by Fedora user jlanda using the blocker tracking app because:

 Default panel functionality:
All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use.

Comment 3 Alessio 2019-03-20 15:31 UTC
Created attachment 1546124 [details]
A screenshot of the issue

Comment 4 Petr Schindler 2019-03-20 15:32:38 UTC
This happens to me too on my installed and fully updated F30. I have Firefox as top icon too and sometimes it doesn't show. My workaround was to remove firefox icon from dash and then return it to same place again.

Comment 5 kwkaess 2019-03-20 17:27:57 UTC
I have this problem, too.

It is always the top icon, and isn't firefox-specific.

The dark bar still works for hover (displays app name) and click (opens the app).

The work-arounds mentioned work, but the fixes aren't permanent. The icon will disappear again.

Comment 6 Kalev Lember 2019-03-20 18:39:40 UTC
Upstream issue: https://gitlab.gnome.org/GNOME/gnome-shell/issues/1053

Comment 7 Geoffrey Marr 2019-03-20 22:05 UTC
Created attachment 1546256 [details]
screenshot of bug

Am also experiencing this on Fedora-WS-Live-30-20190315-n-0. See attached screenshot. Note that after removing the Firefox icon from Favorites and then adding it back at the bottom of the Favorites list (dock), instead of the top, I cannot reproduce the problem.

Comment 8 Phil Wyett 2019-03-21 01:49:55 UTC
*** Bug 1689692 has been marked as a duplicate of this bug. ***

Comment 9 Kalev Lember 2019-03-21 18:11:58 UTC
*** Bug 1691486 has been marked as a duplicate of this bug. ***

Comment 10 Michael Catanzaro 2019-03-23 14:33:02 UTC
+1 blocker

Comment 11 Geoffrey Marr 2019-03-25 18:41:21 UTC
Discussed during the 2019-03-25 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" and an "AcceptedFreezeException" was made as this is a very visible issue in core functionality of the default desktop and affects live images so it cannot be fully fixed with an update. We also find this bug violates the following F30 Final blocker criteria:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-25/f30-blocker-review.2019-03-25-16.01.txt

Comment 12 Mark B 2019-03-26 23:12:47 UTC
This problem happens on up to date Arch Linux as well ever since the update to GNOME 3.32. Doesn't matter which app you move to the top of the dash/dock, it will initially appear fine but disappears after a restart etc (although not always - have not worked out the pattern). All you see for that top app is the small highlight/running bar indicator. Happens on both my notebook and my PC.

Comment 13 Geoffrey Marr 2019-03-27 17:36:24 UTC
Can confirm from comment 12; it is not Firefox specific, whichever icon is switched to the top of the Favorites bar becomes the small highlighted indication of what the actual app should be after a reboot.

Comment 14 Lukas Ruzicka 2019-04-01 14:20:29 UTC
This one still prevails on Fedora Beta RC 1.8.

Comment 15 František Zatloukal 2019-04-16 12:27:35 UTC
Fix has been merged upstream: https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/494 .

Comment 16 Fedora Update System 2019-04-17 16:09:40 UTC
gnome-shell-3.32.0-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 17 Fedora Update System 2019-04-18 18:24:31 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 18 Fedora Update System 2019-04-21 20:32:51 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.