Bug 1690566 - Arm desktops do not have a browser [NEEDINFO]
Summary: Arm desktops do not have a browser
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts   
(Show other bugs)
Version: 30
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: BetaBlocker, F30BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-19 17:23 UTC by Paul Whalen
Modified: 2019-03-25 16:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-03-25 16:15:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
awilliam: needinfo? (pwhalen)


Attachments (Terms of Use)

Description Paul Whalen 2019-03-19 17:23:50 UTC
Description of problem:
Currently ARM desktop images lack a browser due to ongoing build issues with Firefox. 

PR filed to add Epiphany. 
https://pagure.io/fedora-kickstarts/pull-request/501

Comment 1 Adam Williamson 2019-03-19 19:03:13 UTC
Seems a clear blocker per "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments." - +1

Comment 2 Mohan Boddu 2019-03-19 19:35:38 UTC
As per the criteria, its a +1 Blocker

Comment 3 Kevin Fenzi 2019-03-19 19:36:06 UTC
+1 blocker

Comment 4 Adam Williamson 2019-03-19 19:39:58 UTC
That's +3, marking accepted.

Comment 5 Adam Williamson 2019-03-21 15:39:39 UTC
So the PR was merged ahead of Beta-1.4 compose. Can you confirm that epiphany showed up as expected? Thanks!

Comment 6 Adam Williamson 2019-03-21 15:54:06 UTC
Apparently the fix was merged only to master and not the f30 branch so this is *not* fixed in Beta-1.4 :( We should do a respin immediately with this fixed.

Comment 7 Adam Williamson 2019-03-21 15:56:47 UTC
https://pagure.io/fedora-kickstarts/pull-request/505

Comment 8 Adam Williamson 2019-03-25 15:29:07 UTC
pwhalen, can you confirm whether this is fixed in https://kojipkgs.fedoraproject.org/compose/30/Fedora-30-20190323.0/ ? Thanks!

Comment 9 Adam Williamson 2019-03-25 16:15:04 UTC
<adamw> pwhalen: can you confirm whether the ARM images have a browser in the new beta candidate?
<pwhalen> adamw, yes, browser tests complete


Note You need to log in before you can comment on or make changes to this bug.