Bug 169057 - nightly yum cron updates not shown by logwatch
nightly yum cron updates not shown by logwatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 12:51 EDT by long
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 10:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new file (1.32 KB, text/plain)
2005-12-02 12:48 EST, long
no flags Details

  None (edit)
Description long 2005-09-22 12:51:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.5.2

Description of problem:
I have the nightly yum update cron job turned on.  Many times it shows updates applied in /var/log/yum.log.  In FC4 these updates show up in the output from logwatch that is sent out daily.  In FC3 these updates never appear to show up in the logwatch output.  

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1.FC3.1

How reproducible:
Always

Steps to Reproduce:
1.  chkconfig yum on
2.  wait until yum updates something during the nightly run
3.
  

Actual Results:  I get logwatch reports but nothing about yum updates is included in those.


Expected Results:  As I get in FC4 I should see what yum did overnight.


Additional info:
Comment 1 Ivana Varekova 2005-11-21 05:01:46 EST
Thank you for your notice.
The fixed version is on 
http://people.redhat.com/varekova/logwatch-5.2.2-1.FC3.2.test.noarch.rpm,
could you please test it?
This version will probably be in update soon. 
Comment 2 Ivana Varekova 2005-11-24 04:04:36 EST
This bug is fixed in the last fc3 logwatch update (logwatch-5.2.2-1.FC3.2).
If these problem is still present in this version please open this bug.
Comment 3 long 2005-11-30 11:27:05 EST
Hmm, it didn't appear to work with logwatch-5.2.2-1.FC3.2.test.  Sorry it took
so long, I finally had some yum nightly updates go through.  I'll install
logwatch-5.2.2-1.FC3.2 but I'm guessing it is the same package so it still won't
show the nightly yum updates.
Comment 4 long 2005-11-30 11:41:01 EST
I notice that the yum filter is configured to use the US date ("%m/%d/%y"). 
However my yum.log looks like:

Nov 29 04:26:32 Updated: selinux-policy-targeted-sources.noarch 1.17.30-3.19

Shouldn't the yum filter be using std date ("%b %d")?

Comment 5 Ivana Varekova 2005-12-01 03:15:48 EST
Please could you send me the log files (or the germane part of them), which
demonstrate this problem?
Thank you.
Comment 6 long 2005-12-02 12:48:39 EST
Created attachment 121770 [details]
new file

Here's the fix, put this in /etc/log.d/scripts/logfiles/yum/applyupdate and
give it execute permission.  Seems to work for me (i.e. logwatch now shows the
nightly automatic yum updates).
Comment 7 Ivana Varekova 2005-12-05 10:01:46 EST
Thank you for bug report.
This is another problem - logwatch don't process yum logs at all. It is fixed in
logwatch-5.2.2-1.FC3.3. 
If there is any problem please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.