Bug 169060 - Failed Dependencies: libc.so.6 is needed by XXX
Summary: Failed Dependencies: libc.so.6 is needed by XXX
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-22 17:31 UTC by Jon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 22:41:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon 2005-09-22 17:31:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I try to install any package requiring glibc, the install fails with the message:
Error: failed dependencies:
     libc.so.6 (GLIBC_2.4) is needed by [package name]

My research shows that libc.so.6 is part of the glibc-2.3.5-10 rpm package which is installed during the FC4 install.  glibc-common of the same version is also installed.

I have tried numerous clean installs on two different boxes (Compaq ML370-G2) with the exact same results.  I have even tried to download and install newer version of glibc, but the system (rpm) refuses to install or upgrade glibc saying:
Error: Failed: dependencies:
     glibc-common = 2.3.5-10.3 is needed by glibc-2.3.5-10.3.i686
     glibc = 2.3.5-10 is needed by (installed) glibc-headers-2.3.5-10.i386
     glibc = 2.3.5-10 is needed by (installed) glibc-devel-2.3.5-10.i386

Help!  I really need to get these packages installed and get these boxes up and running.

Version-Release number of selected component (if applicable):
glibc-2.3.5-10

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh libxml2-2.6.22-1.i386.rpm
2. rpm -ivh libxslt-1.1.15-1.i386.rpm
3.
  

Actual Results:  error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by libxml2-2.6.22-1.i386

error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by libxslt-1.1.15-1.i386

Expected Results:  Packages should have installed without error

Additional info:

Comment 1 Jakub Jelinek 2005-09-22 22:41:33 UTC
That means you are trying to install a package that has been built against
glibc-2.3.90 (probably rawhide package) on FC4 where you have glibc-2.3.5
installed.  Don't do that. Either you need to upgrade to rawhide glibc,
or you need to use just packages built for FC4 or earlier.


Note You need to log in before you can comment on or make changes to this bug.