Bug 1690698 - default to Hangul mode not direct EN input method?
Summary: default to Hangul mode not direct EN input method?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-hangul
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 03:10 UTC by Jens Petersen
Modified: 2019-08-07 07:11 UTC (History)
7 users (show)

Fixed In Version: ibus-hangul-1.5.1-7.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 08:18:44 UTC


Attachments (Terms of Use)

Description Jens Petersen 2019-03-20 03:10:21 UTC
Description of problem:
ibus-hangul default to direct EN input not Hangul

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. User starts in xkbd layout Input Source
2. Switch to Hangul IME

Actual results:
2. still in a direct input

Expected results:
2. switch to Hangul input

Additional info:
Seems a suboptimal default for Fedora and inconsistent with CJ.

Comment 1 fujiwara 2019-03-20 03:29:52 UTC
I'm not sure if this can be an issue for Hangul users.

Comment 2 Peng Wu 2019-03-22 08:18:44 UTC
Updated ibus-hangul to change default mode to 'hangul' in Fedora rawhide.

Let us see whether it is okay for Hangul users.

Comment 3 fujiwara 2019-03-22 09:17:17 UTC
CC'ing Hangul users.

Fedora rawhide is now modified the default input mode:
https://src.fedoraproject.org/rpms/ibus-hangul/c/16f71de138ae1d6cd865fc118bd30c8b40c72c78?branch=master


I'd ask if Hangul users can accept the change since I think the maintainers set the default to 'latin' with a certain will in ibus-hangul 1.5.1.

Comment 4 Changwoo Ryu 2019-03-24 05:10:42 UTC
Usually Korean users just use ibus-hangul ONLY in GNOME, without XKB based input. (It is because the input source switching in GNOME is quite different with the Korean/English switching that has been used for decades. I tried to modify GNOME to make them compatible as possible but it was not very successful.) In this case, the initial direct EN mode is the expected default.

I understand that for those who use hangul and other language engines and switching between them, "KO default" is preferred. But most Korean users don't use ibus-hangul in that way.

Comment 5 fujiwara 2019-03-28 09:44:42 UTC
sangu.fedora: Any comments on it?

I think the request would be different from the point of the actual users.

Comment 6 Changwoo Ryu 2019-08-03 06:31:17 UTC
I'm an actual user. :)  As I mentioned before, the preferred settings are different by use-cases. But this issue is about Fedora. In case of fresh Korean-default Fedora installation, AFAIK ibus-hangul will be set as the only input source by gnome-initial-setup. Then Latin (direct EN) is the expected default.

Comment 7 Peng Wu 2019-08-06 09:36:45 UTC
Okay, reverted this change in Fedora rawhide.

Comment 8 fujiwara 2019-08-07 07:11:22 UTC
Thank you.


Note You need to log in before you can comment on or make changes to this bug.