Bug 1690701 - Cannot change VM's flavor when creating a VM from yaml (not from the wizard)
Summary: Cannot change VM's flavor when creating a VM from yaml (not from the wizard)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 03:16 UTC by Guohua Ouyang
Modified: 2020-07-13 17:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:11:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4469 0 None closed Bug 1690701: Update the VM yaml format at the VM creation options 2020-06-29 10:00:54 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:11:16 UTC

Description Guohua Ouyang 2019-03-20 03:16:00 UTC
Description of problem:
Create a VM with 64M Memory, go to overview page and edit it, the memory is loading as 64G memory. If user does not notice it and save the VM, the VM memory size is becoming large unexpectedly.

Besides it, user can only input integer, float is not allowed there.

Version-Release number of selected component (if applicable):
kubevirt-web-ui:v1.4.0-14.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2019-03-27 00:38:44 UTC
since it is "low", "low" and would be hard to hit in practice and the impact is an annoyance but does not break anything, targeting to 2.1

Comment 2 Filip Krepinsky 2019-07-23 15:53:20 UTC
The flavor editing feature is missing in 2.1 so targeting 2.2

Comment 3 Ido Rosenzwig 2019-11-11 16:46:00 UTC
kubevirt-web-ui is no longer used as the primary plugin for the console.
Thus, the problem described in https://bugzilla.redhat.com/show_bug.cgi?id=1690701#c0 doesn't happen anymore.

But another issue does occur:
If a user create a VM from YAML, not from the wizard, the VM's flavor cannot be changed via the overview page

Comment 4 Tomas Jelinek 2019-11-12 08:32:35 UTC
So after offline discussion with Ido, the issue is this:
If you create the VM using a yaml which does not contain the template/flavor/os annotations, you can not edit the VM's memory/CPU in vm details. It does work for VMs which are created using the wizard.

It is a rather normal thing that if the VM is not created using the wizard, the UI is able to work with it but not all the features will work. It would be nice to be able to cpu/memory independently of the flavor, but it is that critical. Moving to 4.4

Comment 7 Guohua Ouyang 2020-03-31 07:33:02 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 9 errata-xmlrpc 2020-07-13 17:11:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.