Bug 1690708 - The OLM API group version is inappropriate
Summary: The OLM API group version is inappropriate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 04:29 UTC by Jian Zhang
Modified: 2019-06-04 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:19 UTC

Description Jian Zhang 2019-03-20 04:29:44 UTC
Description of problem:
The API group version(v1alpha1) is inappropriate as a GA feature.

Version-Release number of selected component (if applicable):
               io.openshift.build.commit.id=5159b0a1c0dfe2cb76eb706afb4e3cc2ac4447fd
               io.openshift.build.commit.url=https://github.com/operator-framework/operator-lifecycle-manager/commit/5159b0a1c0dfe2cb76eb706afb4e3cc2ac4447fd
               io.openshift.build.source-location=https://github.com/operator-framework/operator-lifecycle-manager

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.0.
2. Install an operator on the Web console, for example, etcd-operator.
3. Check the subscription/InstallPlan/csv resources.

Actual results:
[jzhang@dhcp-140-18 ocp119]$ oc get sub etcd -o yaml
apiVersion: operators.coreos.com/v1alpha1
kind: Subscription
...
[jzhang@dhcp-140-18 ocp119]$ oc get ip install-bpf6g -o yaml
apiVersion: operators.coreos.com/v1alpha1
kind: InstallPlan
metadata:
...
[jzhang@dhcp-140-18 ocp119]$ oc get csv etcdoperator.v0.9.2 -o yaml
apiVersion: operators.coreos.com/v1alpha1
kind: ClusterServiceVersion
metadata:
...

The apiVersion is "operators.coreos.com/v1alpha1"

Expected results:
As a GA feature, the "v1alpha1" is inappropriate. Should change it to "v1".

Additional info:

Comment 1 Evan Cordell 2019-03-29 18:05:38 UTC
This is fixed here: https://github.com/operator-framework/operator-lifecycle-manager/pull/774

The decision from Jessica/Clayton was to make OperatorGroup and PackageManifests v1, and keep the other objects at v1alpha1.

Comment 3 Jian Zhang 2019-04-03 08:52:22 UTC
[jzhang@dhcp-140-18 ocp43]$ oc get og olm-operators -o yaml |grep api
apiVersion: operators.coreos.com/v1
[jzhang@dhcp-140-18 ocp43]$ oc get packagemanifest packageserver -o yaml|grep api
apiVersion: packages.operators.coreos.com/v1

[jzhang@dhcp-140-18 ocp43]$ oc get sub packageserver -o yaml|grep api
apiVersion: operators.coreos.com/v1alpha1
[jzhang@dhcp-140-18 ocp43]$ oc get ip install-kswwg -o yaml|grep api
apiVersion: operators.coreos.com/v1alpha1
[jzhang@dhcp-140-18 ocp43]$ oc get csv etcdoperator.v0.9.4-clusterwide -o yaml|grep apiVersion
apiVersion: operators.coreos.com/v1alpha1
[jzhang@dhcp-140-18 ocp43]$ oc get catsrc olm-operators -o yaml|grep apiVersion
apiVersion: operators.coreos.com/v1alpha1

Per comment 1, LGTM, verify it.
OLM version:
               io.openshift.build.commit.id=9ba3512c5406b62179968e2432b284e9a30c321e
               io.openshift.build.commit.url=https://github.com/operator-framework/operator-lifecycle-manager/commit/9ba3512c5406b62179968e2432b284e9a30c321e

Comment 5 errata-xmlrpc 2019-06-04 10:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.