Bug 1690736 - Need to update the description about disable federation in Federation installation UI
Summary: Need to update the description about disable federation in Federation install...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Paul Morie
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 06:42 UTC by Qin Ping
Modified: 2019-06-04 10:46 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:19 UTC

Description Qin Ping 2019-03-20 06:42:17 UTC
Description of problem:
Need to update the description about disable federation in Federation installation UI


Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-19-004004   True        False         3h39m   Cluster version is 4.0.0-0.nightly-2019-03-19-004004

Federation v2 controller-manager version: version.Info{Version:"0.0.6", GitCommit:"de6a0a909418f5ddf2d04d232b0ca55aa9cffb49", GitTreeState:"clean", BuildDate:"2019-03-14T00:43:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
100%

Steps to Reproduce:
1. Login webconsole with kubeadmin user
2. Catalog->OperatorHub->Federation


In the install UI, chapter: Disabling federation for an API type

kubefed2 disable deployments --federation-namespace=<namespace>
should be:
kubefed2 disable deployments.extensions --federation-namespace=<namespace>

"This command deletes the FederatedTypeConfig for the API type being disabled.", actually if we want to delete the federatedtypeconfig object we need use param --delete-from-api.

Comment 1 Paul Morie 2019-03-21 15:26:34 UTC
This will be fixed in the next version of the CSV.

Comment 2 Paul Morie 2019-03-29 00:09:28 UTC
Should be fixed in 0.0.7 CSV

Comment 4 Qin Ping 2019-04-01 04:49:27 UTC
Verified with:
$ oc get clusterversion
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.ci-2019-03-31-223338   True        False         91m       Cluster version is 4.0.0-0.ci-2019-03-31-223338

Federation v2 controller-manager version: version.Info{Version:"v0.0.7", GitCommit:"3e251608ca5357080b95a0bedc45759652f17d29", GitTreeState:"clean", BuildDate:"2019-03-22T22:30:26Z", GoVersion:"go1.11.2", Compiler:"gc", Platform:"linux/amd64"}

Comment 6 errata-xmlrpc 2019-06-04 10:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.