Bug 1690823 - machine-os-content image is from registry.svc.ci.openshift.org but not quay.io
Summary: machine-os-content image is from registry.svc.ci.openshift.org but not quay.io
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Tim Bielawa
QA Contact: Sunil Choudhary
URL:
Whiteboard:
: 1669962 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 10:05 UTC by Johnny Liu
Modified: 2019-10-22 02:33 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:19 UTC

Description Johnny Liu 2019-03-20 10:05:07 UTC
Description of problem:
Found only "machine-os-content" image is from registry.svc.ci.openshift.org, other components are from quay.io.

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-19-004004

How reproducible:
Always


Steps to Reproduce:
1. Install a cluster using 4.0.0-0.nightly-2019-03-19-004004 payload
2. Check all images in this payload image
3.

Actual results:
 oc adm release info --pullspecs
Name:      4.0.0-0.nightly-2019-03-19-004004
Digest:    sha256:5535717a5cabb2c5587567a5c32d35e4d8ac238e9459a6ffe14c789b42ac5cc2
Created:   2019-03-18 20:41:54 -0400 EDT
OS/Arch:   linux/amd64
Manifests: 258

Release Metadata:
  Version:  4.0.0-0.nightly-2019-03-19-004004
  Upgrades: <none>

Component Versions:
  Kubernetes 1.12.4

Images:
  NAME                                          PULL SPEC
<--snp-->
  machine-os-content                            registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-03-19-004004@sha256:65406dd82ead5a7cc6bd34f9c8e49b6212a7ab1db9cc9d33ba14613719e3771f
<--snp-->

Found only "machine-os-content" image is from registry.svc.ci.openshift.org, other components are from quay.io.

Expected results:
"machine-os-content" should keep consistent with others.


Additional info:

Comment 3 Clayton Coleman 2019-03-21 00:45:52 UTC
This is not a bug, but how nightly builds are created.  The presence of a registry.svc.ci image in a release published to quay would be a bug.

Comment 7 Vikas Laad 2019-04-29 21:43:35 UTC
*** Bug 1669962 has been marked as a duplicate of this bug. ***

Comment 8 Clayton Coleman 2019-05-02 16:15:21 UTC
This is already fixed.  The promote job now sets the correct URL.

Comment 15 errata-xmlrpc 2019-06-04 10:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.