Bug 169094 - vncpasswd segfaults on passwords longer than 11 chars
vncpasswd segfaults on passwords longer than 11 chars
Status: CLOSED DUPLICATE of bug 160471
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-22 18:16 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-22 18:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-09-22 18:16:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
vncpasswd segfaults if longer passwords are given

Version-Release number of selected component (if applicable):
vnc-server-4.1.1-10.1

How reproducible:
Always

Steps to Reproduce:
1. vncpasswd /path/to/file
2. Password: 123456789012
3. Verify: 123456789012

  

Actual Results:  $ vncpasswd .vnc/passwd
Password:
Verify:
Passwords don't match - try again
*** glibc detected *** vncpasswd: free(): invalid next size (fast): 0x090f7110 ***
======= Backtrace: =========
/lib/libc.so.6[0x5a0124]
/lib/libc.so.6(__libc_free+0x77)[0x5a065f]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0xac29c9]
/usr/lib/libstdc++.so.6(_ZdaPv+0x1d)[0xac2a15]
vncpasswd[0x8048fe4]
vncpasswd[0x804919a]
vncpasswd(__gxx_personality_v0+0x355)[0x8048d0d]
/lib/libc.so.6(__libc_start_main+0xdf)[0x551d5f]
vncpasswd(__gxx_personality_v0+0x59)[0x8048a11]
======= Memory map: ========
00111000-0011a000 r-xp 00000000 08:01 424357     /lib/libgcc_s-4.0.1-20050727.so.1
0011a000-0011b000 rwxp 00009000 08:01 424357     /lib/libgcc_s-4.0.1-20050727.so.1
0051f000-00539000 r-xp 00000000 08:01 424353     /lib/ld-2.3.5.so
00539000-0053a000 r-xp 00019000 08:01 424353     /lib/ld-2.3.5.so
0053a000-0053b000 rwxp 0001a000 08:01 424353     /lib/ld-2.3.5.so
0053d000-00660000 r-xp 00000000 08:01 424354     /lib/libc-2.3.5.so
00660000-00662000 r-xp 00123000 08:01 424354     /lib/libc-2.3.5.so
00662000-00664000 rwxp 00125000 08:01 424354     /lib/libc-2.3.5.so
00664000-00666000 rwxp 00664000 00:00 0
00668000-0068b000 r-xp 00000000 08:01 424355     /lib/libm-2.3.5.so
0068b000-0068c000 r-xp 00022000 08:01 424355     /lib/libm-2.3.5.so
0068c000-0068d000 rwxp 00023000 08:01 424355     /lib/libm-2.3.5.so
009a9000-009aa000 r-xp 009a9000 00:00 0
00a0e000-00aee000 r-xp 00000000 08:01 1757520    /usr/lib/libstdc++.so.6.0.5
00aee000-00af3000 rwxp 000df000 08:01 1757520    /usr/lib/libstdc++.so.6.0.5
00af3000-00af9000 rwxp 00af3000 00:00 0
08048000-0804b000 r-xp 00000000 08:01 1759996    /usr/bin/vncpasswd
0804b000-0804d000 rw-p 00002000 08:01 1759996    /usr/bin/vncpasswd
090f7000-09118000 rw-p 090f7000 00:00 0          [heap]
b7e00000-b7e21000 rw-p b7e00000 00:00 0
b7e21000-b7f00000 ---p b7e21000 00:00 0
b7f45000-b7f47000 rw-p b7f45000 00:00 0
b7f55000-b7f57000 rw-p b7f55000 00:00 0
bff41000-bff57000 rw-p bff41000 00:00 0          [stack]
Aborted


Expected Results:  No such segfault

Additional info:
Comment 1 Tim Waugh 2005-09-22 18:18:12 EDT

*** This bug has been marked as a duplicate of 160471 ***

Note You need to log in before you can comment on or make changes to this bug.