Bug 1691096 - Warning message about crio.service being marked executable
Summary: Warning message about crio.service being marked executable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Lokesh Mandvekar
QA Contact: weiwei jiang
URL:
Whiteboard:
: 1691094 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-20 20:47 UTC by Micah Abbott
Modified: 2019-06-04 10:46 UTC (History)
10 users (show)

Fixed In Version: cri-o-1.12.10-2.rhaos4.0.git2c94bb7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:23 UTC

Comment 1 Micah Abbott 2019-03-20 20:54:14 UTC
*** Bug 1691094 has been marked as a duplicate of this bug. ***

Comment 4 Lokesh Mandvekar 2019-03-26 20:10:21 UTC
Btw, bug version and target release probably need to be 4.0 and not 4.1. Can you confirm?

Comment 6 Micah Abbott 2019-03-26 20:36:31 UTC
(In reply to Lokesh Mandvekar from comment #4)
> Btw, bug version and target release probably need to be 4.0 and not 4.1. Can
> you confirm?

No 4.1 is correct.  The initial release of OpenShift 4 will be 4.1

Comment 7 Lokesh Mandvekar 2019-03-26 20:58:25 UTC
(In reply to Micah Abbott from comment #6)
> (In reply to Lokesh Mandvekar from comment #4)
> > Btw, bug version and target release probably need to be 4.0 and not 4.1. Can
> > you confirm?
> 
> No 4.1 is correct.  The initial release of OpenShift 4 will be 4.1

ack, and 4.1 will have 1.12 and crio 1.13 would be for 4.2??? Just that I'll need to sort things out in brew and perhaps even criotested. Cause right now, I'm pushing changes to criotested's 4.0 directory.

The latest build has been pushed to criotested btw.

Comment 8 weiwei jiang 2019-03-27 10:03:52 UTC
Checked with 4.0.0-0.nightly-2019-03-26-072833, and currently crio is crio-1.12.

If 4.2 will align to crio 1.13, the target release should be aligned to 4.2

Comment 9 weiwei jiang 2019-03-27 10:06:32 UTC
Ignore above comment.

Checked with 4.0.0-0.nightly-2019-03-26-072833, and cri-o is still 1.12.9, need wait new build to verify
cri-o-1.12.9-1.rhaos4.0.gitaac6be5.el7.x86_64

Comment 10 weiwei jiang 2019-04-01 06:41:28 UTC
Still need wait new build since latest build we can got is sill cri-o 1.12.9

# oc get nodes -o wide 
NAME                                              STATUS   ROLES    AGE     VERSION             INTERNAL-IP    EXTERNAL-IP   OS-IMAGE                                           KERNEL-VERSION         CONTAINER-RUNTIME
ip-10-0-130-158.ap-northeast-1.compute.internal   Ready    worker   3h29m   v1.12.4+30e6a0f55   10.0.130.158   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
ip-10-0-139-60.ap-northeast-1.compute.internal    Ready    master   3h38m   v1.12.4+30e6a0f55   10.0.139.60    <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
ip-10-0-147-127.ap-northeast-1.compute.internal   Ready    worker   3h29m   v1.12.4+30e6a0f55   10.0.147.127   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
ip-10-0-150-44.ap-northeast-1.compute.internal    Ready    master   3h39m   v1.12.4+30e6a0f55   10.0.150.44    <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
ip-10-0-172-20.ap-northeast-1.compute.internal    Ready    master   3h39m   v1.12.4+30e6a0f55   10.0.172.20    <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
ip-10-0-174-242.ap-northeast-1.compute.internal   Ready    worker   3h30m   v1.12.4+30e6a0f55   10.0.174.242   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190322.0   4.18.0-80.el8.x86_64   cri-o://1.12.9-1.rhaos4.0.gitaac6be5.el7
# oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-28-030453   True        False         4h3m    Cluster version is 4.0.0-0.nightly-2019-03-28-030453

Comment 11 weiwei jiang 2019-04-04 05:18:46 UTC
Checked and this issue has been fixed, move to verified.

# oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-04-03-202419   True        False         131m    Cluster version is 4.0.0-0.nightly-2019-04-03-202419
# oc get nodes -o wide 
NAME                                              STATUS   ROLES    AGE    VERSION             INTERNAL-IP    EXTERNAL-IP   OS-IMAGE                                                   KERNEL-VERSION         CONTAINER-RUNTIME
ip-10-0-133-19.ap-northeast-1.compute.internal    Ready    worker   135m   v1.12.4+509916ce1   10.0.133.19    <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7
ip-10-0-142-81.ap-northeast-1.compute.internal    Ready    master   144m   v1.12.4+509916ce1   10.0.142.81    <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7
ip-10-0-145-160.ap-northeast-1.compute.internal   Ready    worker   135m   v1.12.4+509916ce1   10.0.145.160   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7
ip-10-0-155-245.ap-northeast-1.compute.internal   Ready    master   144m   v1.12.4+509916ce1   10.0.155.245   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7
ip-10-0-164-166.ap-northeast-1.compute.internal   Ready    master   144m   v1.12.4+509916ce1   10.0.164.166   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7
ip-10-0-167-245.ap-northeast-1.compute.internal   Ready    worker   136m   v1.12.4+509916ce1   10.0.167.245   <none>        Red Hat Enterprise Linux CoreOS 410.8.20190329.0 (Ootpa)   4.18.0-80.el8.x86_64   cri-o://1.12.10-2.rhaos4.0.git2c94bb7.el7

# for i in `oc get nodes -o wide --no-headers | awk '{print $6}'`; do echo "========================= $i =======================";  ssh -i ~/.ssh/private_key.pem -o StrictHostKeyChecking=no -o ProxyCommand='ssh  -i ~/.ssh/private_key.pem -A -o StrictHostKeyChecking=no -o ServerAliveInterval=30 -W %h:%p core@$(oc get service -n openshift-ssh-bastion ssh-bastion -o jsonpath="{.status.loadBalancer.ingress[0].hostname}")' core@$i journalctl -u crio|grep -i -E  "configuration|executable|permission|proceeding"; done
========================= 10.0.133.19 =======================
Killed by signal 1.
========================= 10.0.142.81 =======================
Killed by signal 1.
========================= 10.0.145.160 =======================
Killed by signal 1.
========================= 10.0.155.245 =======================
Killed by signal 1.
========================= 10.0.164.166 =======================
Killed by signal 1.
========================= 10.0.167.245 =======================
Killed by signal 1.

Comment 13 errata-xmlrpc 2019-06-04 10:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.