Bug 169118 - wacom tablet jumps coordinates when used with pen, when used with mouse scroll wheel is reversed
wacom tablet jumps coordinates when used with pen, when used with mouse scrol...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: linuxwacom (Show other bugs)
5.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Aristeu Rozanski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 05:09 EDT by Alex Maier
Modified: 2014-02-12 10:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-12 10:05:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant parts of xorg.conf (1.84 KB, application/octet-stream)
2007-04-18 15:42 EDT, Aristeu Rozanski
no flags Details
modified xorg.conf with sections provided earlier (4.34 KB, text/plain)
2007-04-19 10:24 EDT, Alex Maier
no flags Details

  None (edit)
Description Alex Maier 2005-09-23 05:09:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Red Hat/1.0.6-1.4.2 Firefox/1.0.6

Description of problem:
The tablet works passably, but when used with the pen, the coordinates on screen frequently don't match with the position of the pen on the tablet, which then leads to situations like: mouse is positioned somewhere mid-screen, but pen has reached the edge of the tablet, which is particularly unhelpful when performing a drag-and-drop or drawing, or when trying to access the application menus at the top edge of the screen.

The usual remedy is to stop doing what you are doing and move the pen to the opposite edge of the tablet, thus "resetting" it to the sane state for a while.

This problem occurs particularly frequently when CPU workload is higher.

When using the tablet with the mouse, this problem does not occure at all, but the scroll wheel is reversed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use tablet with pen
2. See coordinates drift apart
3. "Reset" by moving the pen to opposing edges
4. See it happen again
  

Actual Results:  As the malfunction is permanent, it is constantly reproducible. The pen reaches the enge of the tablet before the edge of the screen is reached.

Expected Results:  The tablet coordinates should corrspond to the mouse position on the screen.

Additional info:
Comment 1 Martin Cheatle 2006-08-29 11:37:02 EDT
Does this happen when you startx after the tablet has been plugedin
Comment 2 Alex Maier 2006-08-29 15:21:14 EDT
Yes--it happens every time, whenever used.

The tablet seems not to have the same idea of how big the screen is, and also
seems unsure of where the point 0.0 would be. Sometimes the mouse would be
pretty much in the middle of the screen, with the pen in one of the corners of
the tablet.
Comment 3 Martin Cheatle 2006-08-30 04:24:18 EDT
What is the version of the wacom kernel module and the xwindows driver.

can you supply the logs, /var/log/messages and the Xorg.0.log
Just the bits from when the wacom drivers load.
Comment 4 Alex Maier 2006-09-01 13:26:04 EDT
Let me know whether this answers your questions.

/var/log/messages excerpt:

Aug 28 09:12:45 amaier kernel: usb 1-1.3: new low speed USB device using address 4
Aug 28 09:12:45 amaier kernel: usbhid: probe of 1-1.3:1.0 failed with error -5
Aug 28 09:12:45 amaier kernel: input: Wacom Graphire2 4x5 on usb-0000:00:1d.7-1.3
Aug 28 09:12:45 amaier kernel: usbcore: registered new driver wacom
Aug 28 09:12:45 amaier kernel: drivers/usb/input/wacom.c: v1.30:USB Wacom
Graphire and Wacom Intuos tablet driver
Aug 28 09:12:45 amaier kernel: NET: Registered protocol family 10
Aug 28 09:12:45 amaier kernel: Disabled Privacy Extensions on device c0378f60(lo)
Aug 28 09:12:45 amaier sshd:  succeeded
Aug 28 09:12:45 amaier kernel: IPv6 over IPv4 tunneling driver
Aug 28 09:12:45 amaier kernel: drivers/usb/input/hid-input.c: event field not found
Aug 28 09:12:45 amaier kernel: drivers/usb/input/hid-input.c: event field not found

Xorg.0.log excerpt:

(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "yes"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetGrabKeysState - disabled
SetGrabKeysState - enabled                                                     
                                                   
Comment 5 Aristeu Rozanski 2007-04-04 15:06:09 EDT
Alex, please append your X configuration on this bugzilla, the Xorg.0.log excerpt
doesn't shows anything related to wacom driver.
Comment 6 Alex Maier 2007-04-09 11:24:57 EDT
The InputDevice section of /etc/X11/xorg.conf -- no mention of tablet there,
only mouse. However here it is. If this is not the file you need, let me know.

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection
Comment 7 Aristeu Rozanski 2007-04-09 11:32:06 EDT
Hi Alex,
If you don't use X wacom driver, the tablet will be used along with other mice
(via /dev/input/mice). Please install linuxwacom package and update your xorg.conf
to use the X wacom driver and tell me the results.

Thanks
Comment 8 Alex Maier 2007-04-09 11:42:00 EDT
Aristeu,
I do have the driver installed--had it since I got the tablet.
Which file will indicate whether the driver is being used?
a


up2date linuxwacom

Fetching Obsoletes list for channel: rh-i386-desktop-4...
########################################

Fetching Obsoletes list for channel: helpdesk-dt4-laptop...

Fetching Obsoletes list for channel: helpdesk-dt4-apps...

Fetching Obsoletes list for channel: rh-i386-desktop-4-extras...
########################################

Fetching Obsoletes list for channel: helpdesk-dt4-extras...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated:
linuxwacom
Comment 9 Aristeu Rozanski 2007-04-18 15:38:39 EDT
if you don't have the wacom section on xorg.conf, the driver won't be used.
I'll attach a simple configuration section.
Comment 10 Aristeu Rozanski 2007-04-18 15:42:30 EDT
Created attachment 152947 [details]
relevant parts of xorg.conf

Please notice it's not a complete xorg.conf but only the relevant sections to
be used as example.
Comment 11 Alex Maier 2007-04-19 10:21:29 EDT
Did insert all sections into my xorg.conf and did not see any noticeable
improvement. I am still able to replicate a situation where my stylus arrives at
the end of the tablet's input area before reaching the edge of the screen.
Comment 12 Alex Maier 2007-04-19 10:24:23 EDT
Created attachment 153008 [details]
modified xorg.conf with sections provided earlier
Comment 13 Aristeu Rozanski 2007-05-30 16:25:36 EDT
Alex, does the file /dev/input/uinput-devices/uinput-wacom-graphire4-4x5-tablet
exists in your machine? try using the /dev/input/by-id/<your tablet> file
instead.
Comment 14 Aristeu Rozanski 2008-01-07 11:42:08 EST
Alex, any updates?
Comment 15 Alex Maier 2008-01-07 12:21:39 EST
I am not sure I can follow your instructions correctly. When I run ls on
/dev/input, that's what I get:

$ ls /dev/input/
event0  event2  event4  event6  mice    mouse1
event1  event3  event5  event7  mouse0  mouse2

The problem persists, BTW :)
Comment 16 Aristeu Rozanski 2008-01-07 12:30:55 EST
Hi Alex,
please attach here:
- kernel version
- linuxwacom package version (rpm -qi linuxwacom)
- wdaemon package version (rpm -qi wdaemon)

Thanks
Comment 17 Alex Maier 2008-01-07 14:20:06 EST
kernel-2.6.18-8.1.8.el5


Name        : linuxwacom                   Relocations: (not relocatable)
Version     : 0.7.4.3                           Vendor: Red Hat, Inc.
Release     : 2.el5                         Build Date: Fri 01 Dec 2006 01:09:05
PM EST
Install Date: Mon 01 Oct 2007 11:14:52 AM EDT      Build Host:
hs20-bc2-3.build.redhat.com
Group       : User Interface/X Hardware Support   Source RPM:
linuxwacom-0.7.4.3-2.el5.src.rpm
Size        : 411704                           License: GPL/X11
Signature   : DSA/SHA1, Wed 17 Jan 2007 01:38:40 PM EST, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>

# rpm -qi wdaemon
package wdaemon is not installed



# yum install wdaemon
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
clone-rhel-i386-client-he 100% |=========================| 1.2 kB    00:00     
clone-rhel-i386-client-wo 100% |=========================| 1.2 kB    00:00     
clone-rhn-tools-rhel-i386 100% |=========================| 1.2 kB    00:00     
clone-rhel-i386-client-su 100% |=========================| 1.2 kB    00:00     
clone-rhel-i386-client-5  100% |=========================| 1.2 kB    00:00     
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: wdaemon
Nothing to do
Comment 19 Aristeu Rozanski 2008-02-07 13:36:03 EST
Alex, any news?
Comment 20 Alex Maier 2008-02-07 13:59:15 EST
Since I am using a Red Hat Helpdesk supported system, I had to ask them if that
would mean they won't support my box anymore. It meant exactly that.

So my compromise with them was to install the alternative kernel, test the fix
and then remove it.

Unfortunately, right now the time is bad for me to muck around with my system,
as I have a few deadlines coming up. I will have more time after Feb 18th, and
will report the results to you then.

Cheers,
Alex
Comment 21 Alex Maier 2008-02-20 15:52:28 EST
Tried to install the provided packages today with these results:

[root@amaier ~]# rpm -ivh
/home/amaier/Desktop/kernel-2.6.18-49.el5.wacomtest2.i686.rpm 
Preparing...                ########################################### [100%]
        package kernel-2.6.18-53.1.4.el5 (which is newer than
kernel-2.6.18-49.el5.wacomtest2) is already installed
        package kernel-2.6.18-53.1.6.el5 (which is newer than
kernel-2.6.18-49.el5.wacomtest2) is already installed
[root@amaier ~]# rpm -ivh /home/amaier/Desktop/linuxwacom-0.7.8.3-1.el5.i386.rpm 
Preparing...                ########################################### [100%]
        file /etc/udev/rules.d/60-wacom.rules from install of
linuxwacom-0.7.8.3-1.el5 conflicts with file from package linuxwacom-0.7.4.3-2.el5
        file /usr/bin/wacdump from install of linuxwacom-0.7.8.3-1.el5 conflicts
with file from package linuxwacom-0.7.4.3-2.el5
        file /usr/bin/xidump from install of linuxwacom-0.7.8.3-1.el5 conflicts
with file from package linuxwacom-0.7.4.3-2.el5
        file /usr/bin/xsetwacom from install of linuxwacom-0.7.8.3-1.el5
conflicts with file from package linuxwacom-0.7.4.3-2.el5
        file /usr/lib/libwacomcfg.so.0.0.1 from install of
linuxwacom-0.7.8.3-1.el5 conflicts with file from package linuxwacom-0.7.4.3-2.el5
        file /usr/lib/xorg/modules/input/wacom_drv.so from install of
linuxwacom-0.7.8.3-1.el5 conflicts with file from package linuxwacom-0.7.4.3-2.el5
[root@amaier ~]# 
Comment 22 Aristeu Rozanski 2008-02-20 16:03:39 EST
the kernel issue is ok, you can do:
    rpm -ivh --force /home/amaier/Desktop/kernel-2.6.18-49.el5.wacomtest2.i686.rpm

for the linuxwacom package, use rpm -Uvh when upgrading a package:
    rpm -Uvh /home/amaier/Desktop/linuxwacom-0.7.8.3-1.el5.i386.rpm

the kernel doesn't needs it because it's possible (and it can make sense) to have
more than one version of kernel.
Comment 23 Alex Maier 2008-02-20 16:38:09 EST
Packages installed successfully, I will report on the behaviour in a few days
after I have had a chance to observe. Thanks for your help so far!
Comment 24 Alex Maier 2008-02-22 16:02:56 EST
So after a few days I can tell that the behaviour has been somewhat better, but
under load the coordinates still slip.

Also (and I am not sure whether it is related, but since the only change I had
made was the installation of two packages) I can no longer use RealPlayer--it
says that the resourse is used by another process. This happens even when all
processes that could potentially block the resource (like firefox) are closed...
Comment 25 Aristeu Rozanski 2008-02-25 13:36:11 EST
I don't think RealPlayer should affect the tablet behaviour, but thanks for
reporting.

What kind of load is it? Any easy way to reproduce the problem?
Comment 26 Alex Maier 2008-02-25 15:07:22 EST
It's more like the other way around, RealPlayer fails to access the audio out
device because it is blocked by another process...

As an example of "load" that would impact the tablet behaviour, Thunderbird
Lightning synching with Zimbra once every 15 minutes will surge the CPU load to
85% or more, and at this point the tablet will slip coordinates.
Comment 27 Aristeu Rozanski 2008-04-07 17:18:48 EDT
Alex, just as an update: I'm currently working on the RHEL-4 bugs and I'll be
able to come back to this soon.
Comment 28 Aristeu Rozanski 2008-04-15 12:15:03 EDT
Alex,
there're test RPMs available on
   http://people.redhat.com/arozansk/wacom_rhel5/
there're no changes on those packages that would solve your load problem, but
if you want to try them while I work on your issue I'll appreciate.
Comment 29 Paul Mogren 2008-06-28 08:54:42 EDT
Interested in another data point? I have this issue (without system load) using
Fedora 9 Live USB, all updates installed (except kernel which would render it
unbootable), Graphire 3 USB tablet (I also have a Graphire 2 USB which I haven't
tried)
Comment 30 Aristeu Rozanski 2008-09-08 12:55:17 EDT
Alex, any updates?
Comment 31 Aristeu Rozanski 2008-09-08 13:05:19 EDT
Paul, I've seen this happen on a tablet with a broken pen (i.e. completely random
gaps without anything visible on the system). If you have the chance, try using
this tablet with another pen of the same model.
Comment 33 Alex Maier 2008-09-08 15:04:58 EDT
sorry, i did not have a chance to test the packages yet. is this the freshest one? "linuxwacom-devel-0.7.8.3-3.el5.x86_64.rpm"

I am running Red Hat CSB kernel version 2.6.18-53.1.14.el5 on an i686 machine.

In the meantime, i keep experiencing the problem where the tablet ends before the screen does :)
Comment 34 Aristeu Rozanski 2008-09-08 15:12:47 EDT
Alex,
http://people.redhat.com/arozansk/wacom_rhel5/linuxwacom-0.7.8.3-3.el5.i386.rpm
is the one you're probably looking for. -devel only contains development related
files.
Give it a try and let me know the results
Comment 35 Paul Mogren 2008-09-19 14:17:12 EDT
(In reply to comment #31)
Aristeu, there's no chance my pen is broken. I use it all the time and it works beautifully. For me this (the original complaint) has been a very long-standing issue (years old) with multiple (but not all) linux environments and two different models of tablet/pen.
Comment 36 Aristeu Rozanski 2008-09-19 14:26:02 EDT
Paul,
notice that by "broken" doesn't imply it simply not working. I had experience
with a Intuos3 4x6 with one of those pens. Without apparent reason, no events
were generated. Not even interrupts. It was like the tablet were dead for some
seconds then resumed working without any reason. After debugging in different
machines and even using it on the Mac OS, the result was the same. The tablet
were replaced by a new one, the problem never happened again.

So, that's why I suspected that it could be something like that.
Comment 39 Aristeu Rozanski 2014-02-12 10:06:58 EST
Paul, please feel free to reopen this on RHEL6 if the problem still exists.

Note You need to log in before you can comment on or make changes to this bug.