Bug 1691256 - The image for es proxy container hasn't updated when upgrading logging.
Summary: The image for es proxy container hasn't updated when upgrading logging.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-21 09:32 UTC by Qiaoling Tang
Modified: 2019-06-04 10:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:23 UTC

Description Qiaoling Tang 2019-03-21 09:32:50 UTC
Description of problem:
Upgrade logging via OLM, the es proxy container isn't upgraded. In the new csv, I set all the image tag to "v4.0"

$ oc get deploy -n openshift-operators elasticsearch-operator -o yaml |grep -A 1 IMAGE
        - name: PROXY_IMAGE
          value: quay.io/openshift/origin-oauth-proxy:v4.0

$ oc get deploy elasticsearch-clientdatamaster-0-1 -o yaml |grep image
        image: quay.io/openshift/origin-logging-elasticsearch5:v4.0
        imagePullPolicy: IfNotPresent
        image: quay.io/openshift/origin-oauth-proxy:latest
        imagePullPolicy: IfNotPresent
$ oc get csv
NAME                            DISPLAY                  VERSION   REPLACES                        PHASE
clusterlogging.v0.0.2           Cluster Logging          0.0.2     clusterlogging.v0.0.1           Succeeded
elasticsearch-operator.v0.0.2   Elasticsearch Operator   0.0.2     elasticsearch-operator.v0.0.1   Succeeded

$ oc get csv elasticsearch-operator.v0.0.2 -o yaml |grep IMAGE -A 1
                - name: PROXY_IMAGE
                  value: quay.io/openshift/origin-oauth-proxy:v4.0


The image setting for es proxy container isn't in elasticsearch CR, also, it's not set in CLO deploy.

Version-Release number of selected component (if applicable):
quay.io/openshift/origin-elasticsearch-operator:v4.0

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging via community-operators
2. upgrade logging via OLM
3. check pod image version 

Actual results:


Expected results:


Additional info:

Comment 3 Qiaoling Tang 2019-04-01 02:46:15 UTC
Verification blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1694522

Comment 6 Qiaoling Tang 2019-04-12 03:32:41 UTC
Verified in quay.io/openshift/origin-elasticsearch-operator@sha256:094754d814bc586f7d365f675ca7d005318ad8fe66278e467215abd3bdd94760.

Comment 8 errata-xmlrpc 2019-06-04 10:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.