Bug 1691268 - Cannot add unit for the number of spec.storage.s3.cloudfront.duration
Summary: Cannot add unit for the number of spec.storage.s3.cloudfront.duration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-21 09:53 UTC by Wenjing Zheng
Modified: 2019-06-04 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The type used is not supporting suffixes during deserialization. Consequence: Impossible to use the suffix. Fix: Change the type. Result: Possible to use the suffix.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:23 UTC

Description Wenjing Zheng 2019-03-21 09:53:27 UTC
Description of problem:
Cannot use integer plus unit for spec.storage.s3.cloudfront.duration:
E0321 09:35:34.310761       1 reflector.go:134] github.com/openshift/cluster-image-registry-operator/pkg/generated/informers/externalversions/factory.go:101: Failed to list *v1.Config: v1.ConfigList.Items: []v1.Config: v1.Config.Spec: v1.ImageRegistrySpec.Storage: v1.ImageRegistryConfigStorage.S3: v1.ImageRegistryConfigStorageS3.CloudFront: v1.ImageRegistryConfigStorageS3CloudFront.PrivateKey: v1.SecretKeySelector.KeypairID: Duration: read int64: unexpected character: ", error found in #10 byte of ...|on":"500s","keypairI|..., bigger context ...|//d1bdguld7kb141.cloudfront.net","duration":"500s","keypairID":"APKAJQH55DVQSUIPBLPW","privateKey":{|...

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-20-153904

How reproducible:
always

Steps to Reproduce:
1.oc edit configs.imageregistry.operator.openshift.io
  storage:
    s3:
      bucket: image-registry-ap-northeast-1-aed1e266c9d64fdab6fb75cdd3146065
      encrypt: true
      region: ap-northeast-1
      cloudFront:
         baseURL: https://zzzzzzzzzzzzzz     
         privateKey:
           key: zzzzzzzzzzzzzzzz
           name: mysecret
         keypairID: zzzzzzzzzzzzzzzz       
         duration: 500s
2. Check operator log

Actual results:
Error will appear and registry pod won't restart.

Expected results:
Integer + unit should work according to https://docs.docker.com/registry/configuration/#cloudfront.

Additional info:

Comment 2 Wenjing Zheng 2019-03-26 07:32:04 UTC
Bug has not been merged to latest available version now, will wait for the fix to verify again:
E0326 07:30:35.140959       1 reflector.go:134] github.com/openshift/cluster-image-registry-operator/pkg/generated/informers/externalversions/factory.go:101: Failed to list *v1.Config: v1.ConfigList.Items: []v1.Config: v1.Config.Spec: v1.ImageRegistrySpec.Storage: v1.ImageRegistryConfigStorage.S3: v1.ImageRegistryConfigStorageS3.CloudFront: v1.ImageRegistryConfigStorageS3CloudFront.PrivateKey: v1.SecretKeySelector.KeypairID: Duration: read int64: unexpected character: ", error found in #10 byte of ...|n":"3000s","keypairI|..., bigger context ...|/d2jjws6sn9fo5b.cloudfront.net","duration":"3000s","keypairID":"APKAJQH55DVQSUIPBLPQ","privateKey":{|...
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-23-222829   True        False         29h     Cluster version is 4.0.0-0.nightly-2019-03-23-222829

Comment 3 Wenjing Zheng 2019-04-03 09:39:28 UTC
Verified with below version:4.0.0-0.10

Comment 5 errata-xmlrpc 2019-06-04 10:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.