Bug 1691287 - LibreOffice does not prompt for printer authentication
Summary: LibreOffice does not prompt for printer authentication
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libreoffice
Version: 8.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
: 1681002 (view as bug list)
Depends On:
Blocks: 1681041
TreeView+ depends on / blocked
 
Reported: 2019-03-21 10:55 UTC by Divya
Modified: 2019-11-05 20:54 UTC (History)
5 users (show)

Fixed In Version: libreoffice-6.0.6.1-18.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:54:23 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
fixed patch (12.62 KB, application/mbox)
2019-08-12 19:43 UTC, Caolan McNamara
no flags Details


Links
System ID Priority Status Summary Last Updated
Document Foundation 53029 None None None 2019-03-21 10:55:07 UTC
Red Hat Product Errata RHBA-2019:3354 None None None 2019-11-05 20:54:28 UTC

Description Divya 2019-03-21 10:55:08 UTC
Description of problem:
Libreoffice does not prompt for printer authentication. So printing to authenticated windows printers, for example, does not work from LibreOffice.
Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Open a document in libreoffice and submit for printing. Printer should be configured for authentication

Actual results:
Authentical dialog does not pop up for username and password.

Expected results:
Authentication dialog should pop allowing the user to authenticate and get the document printed.

Additional info:
There is an upstream bugzilla for the same issue available at https://bugs.documentfoundation.org/show_bug.cgi?id=53029.

Comment 1 Caolan McNamara 2019-03-21 11:07:36 UTC
*** Bug 1681002 has been marked as a duplicate of this bug. ***

Comment 2 Caolan McNamara 2019-03-26 12:13:44 UTC
submitted https://gerrit.libreoffice.org/#/c/69739/ for upstream master

Comment 4 Bill Sanford 2019-06-25 14:56:37 UTC
Verified as Sanity Only.

Comment 5 Jiri Koten 2019-06-25 14:58:03 UTC
Hi Divya,

can I ask You to verify the bz?

Thank You!

-Jiri

Comment 9 Caolan McNamara 2019-08-12 19:43:48 UTC
Created attachment 1603032 [details]
fixed patch

I can reproduce the crash

to set up an env where this can be reproduced add a printer, then

service cups stop

edit /etc/cups/printers.conf
add a line to the printer conf of

AuthInfoRequired username, password

save and
service cups start
now print to the printer from gedit and confirm there is a authentication dialog. Try from LibreOffice, right now it crashes, when clearly it shouldn't. nullptr reference on a forgotten field

Comment 15 Bill Sanford 2019-08-20 13:41:12 UTC
Divya, the build has been updated and you should have the customer test with the libreoffice-6.0.6.1-19.el8 build.

Comment 19 errata-xmlrpc 2019-11-05 20:54:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3354


Note You need to log in before you can comment on or make changes to this bug.