Bug 169132 - define QTINC/QTLIB in qt.sh/qt.csh
define QTINC/QTLIB in qt.sh/qt.csh
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: FutureFeature
Depends On:
Blocks: 212722
  Show dependency treegraph
 
Reported: 2005-09-23 10:30 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 05:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-09-23 10:30:58 EDT
A large class of kde applications have issues building properly on x86_64
because they have trouble finding qt (usually lib != lib64 assumptions, etc). 
The workaround is usually to either define env vars QTINC/QTLIB (or use
./configure --with-qt-includes/--with-qt-libraries) pointing to the right place.

A lot of duplicated/extra effort could be avoided if QTINC and QTLIB were
already (correctly) defined in /etc/profile.d/qt.(sh|csh), adding lines like

qt.sh:
# Qt initialization script (sh)
if [ -z "$QTDIR" ] ; then
  QTDIR=...
  QTINC="${QTDIR}/include"
  QTLIB="${QTDIR}/lib"
fi

qt.csh:
# Qt initialization script (csh)
if ( ! $?QTDIR ) then
  setenv QTDIR ...
  setenv QTINC "${QTDIR}/include"
  setenv QTLIB "${QTDIR}/lib"
endif
Comment 1 Ngo Than 2005-09-26 05:17:48 EDT
yes, it makes sense to add this in the qt.sh/qt.tcsh. It have already added
this into qt-3_3_5-3. This change will also be included in qt for FC3/FC4. Many
thanks for your report.
Comment 2 Rex Dieter 2006-04-05 08:30:23 EDT
Can we get a FC-4 (update) release including this soon please?
Comment 3 Ngo Than 2006-04-20 05:03:40 EDT
i will release qt-3.3.4-15.5 including this change for fc4-update today.
sorry for delay!

Note You need to log in before you can comment on or make changes to this bug.