Bug 169133 - Sensors applet crashes on startup
Sensors applet crashes on startup
Product: Fedora
Classification: Fedora
Component: gnome-applet-sensors (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Aaron Kurtz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-09-23 10:36 EDT by Dave Jenkins
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-27 02:45:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Stack trace of crash, captured by bug buddy. (2.59 KB, text/plain)
2005-09-23 10:37 EDT, Dave Jenkins
no flags Details
/etc/sysconfig/lm_sensors (1.44 KB, text/plain)
2005-09-24 05:31 EDT, Dave Jenkins
no flags Details

  None (edit)
Description Dave Jenkins 2005-09-23 10:36:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
I ran yum update today and got gnome-applet-sensors-1.4-1.fc4 (as well as kernel-2.6.12-1.1456). After rebooting with the new kernel, the sensors applet crashed during startup. It caused gnome panel to crash too. I've tried re-starting  the sensors applet a few times but it crashed each time. I have had to delete it from my panel in order to allow the panel to function.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start a desktop session.
2. Wait for bug buddy to inform me that the sensors applet has crashed.

Actual Results:  Sensors applet crashed.

Expected Results:  Sensors applet should start & work.

Additional info:

Will attach stack trace of crash, which shows an assert failure in sensors_applet_gconf_paths_valid.
Comment 1 Dave Jenkins 2005-09-23 10:38:02 EDT
Created attachment 119183 [details]
Stack trace of crash, captured by bug buddy.
Comment 2 Aaron Kurtz 2005-09-23 19:56:22 EDT
1.4 and kernel 2.6.12-1.1456_FC4 works for me. I'll take a look at this. Could
you give me your /etc/sysconfig/lm_sensors ? 
Comment 3 Dave Jenkins 2005-09-24 05:31:53 EDT
Created attachment 119222 [details]

I have reverted to gnome-applet-sensors-1.0-1.fc4 which is working fine.
Comment 4 Aaron Kurtz 2005-09-25 19:21:39 EDT
Quoting Alex Murray, sensors-applet author: "The upgrade from 1.0 to 1.4 is not
directly compatible, so you will need to first remove the applet from the panel,
then install the new version and re-add it to the panel."

It worked for me without this step (I think - perhaps I wasn't logged in when
it updated), but that's what he says. Does it work if
you upgrade in this manner?
Comment 5 Dave Jenkins 2005-09-26 06:07:31 EDT
Yes, removing, updating & re-adding fixed it. Thanks!

Note You need to log in before you can comment on or make changes to this bug.